The World Simplified is a Virtual World

The Adventures of Justin Zarb and Dave Falkus in the Virtual Jungle

Beta 4.5: Application Virtualization Error 25120

Beta 4.5: Application Virtualization Error 25120

  • Comments 4
  • Likes

I pinged BoruRR internally about this a while back when discussions came up on the Application Virtualization Forum.

One of the things that you should watch out for when installing Application Virtualization 4.5 on Windows Server 2008 is the IIS settings.

We require with the current November 2007 Beta certain IIS 6 compatibility settings enabled before you install the server on Windows Server 2008 else you may face the following error;

"Error 25120. The installation program was unable to create the required IIS Virtual Directory”

To install the IIS 6.0 Management Compatibility Components by using the Windows Server 2008 Server Manager

  1. Click Start, click Administrative Tools and then Server Manager.

  2. In the left navigation pane, expand Roles, and then right-click Web Server (IIS) and select Add Role Services.

  3. On the Select Role Services pane, scroll down to IIS 6 Management Compatibility.

  4. Select the check boxes for IIS 6 Metabase Compatibility and IIS 6 Management Console.

  5. Click Next from the Select Role Services pane, and then click Install at the Confirm Installations Selections pane.

  6. Click Close to leave the Add Role Services wizard.

Reference:  http://technet.microsoft.com/en-us/library/bb397374(EXCHG.80).aspx

It should look a bit like this when your done!!

iis7

Honestly Windows Server 2008 rocks..... Windows Server 2008 with Application Virtualization 4.5 Rocks even more....... and Windows Server 2008 with Hyper-V running Windows Server 2008 with Application Virtualization 4.5 beta is the best!!!

Comments
  • I have comfirmed by two machine that "IIS Management Scripts and Tools" is also required to get rid of E25120. The item is checked in the picture but not mentioned.

  • Thanks Joey, Your right for the RC build however the above was for the Beta!

    I will blog about all the bits you need to do to get it all up and running with the RC and win2k8 soon.

  • Even with the final release, the above items mentioned are all required. Thanks!

  • This was also needed on my Server 2008 R2 install-  "IIS Management Scripts and Tools".  Thanks!

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment