VirtualVibes

Thamim Karim on a virtual vibe...

Installing the App-V 5.0 Client and configuring it with a Publishing Server

Installing the App-V 5.0 Client and configuring it with a Publishing Server

  • Comments 22
  • Likes

This post has moved here

Comments
  • Good blog, just what i was looking for. You might want to add that before importing the appvlient module you need to enable running scripts with "Set-ExecutionPolicy RemoteSigned”.  SP1 for App-V 5 has been released  but the new setup based on SP1 has the same steps as listed above so you can also add that it Applies to App-V 5.0 SP1.

  • Forgot to sign in, I have added the previous comment.

  • Good shout Danny and useful info.I tend to avoid adding the remote-signed stuff into the blogs so I don't need to repeat myself in every post that contains PowerShell but definitely worth note for those who aren't familiar with it!

  • Great Article.

  • It seems when using a publishing server the applications are not published globally to all users. Can the client obtain that configuration setting from the publishing server or does one need to modify each package at the client level?

  • You can do this centrally, check out this post: blogs.technet.com/.../enabling-computer-based-targeting-in-app-v-5-0.aspx

  • Thanks

  • no probs!

  • Excellent blog, more greese to your elbows

  • Thanks John

  • Hi Thamim,

       I am really struggling answer for this Question..

      1. How can I use the XML files [Deployment Config and User Config] of App-v 5.0 packages, If I install the package only through MSI. Is there any command line options to pass these XML files along with MSI or how it will be handled. Thanks

  • Hi,

    There isn't a switch. You have to understand the .msi is simply a wrapper for the PowerShell commands that adds your package in via standalone mode. The .msi isn't really designed for mass deployment, rather offers an option for unmanaged end users. If you do need to use the .msi then simply run the relevant PowerShell afterwards to specify the .xml. Does that help?

  • Really I want to know what is the Command line I have to use for having this XML after installing the MSI.

  • Dear Thamim,

    Thank you for keep blogging on App-V.

    I have been using the product since 4.5 version, I like this product.

    I have an issue with App-V 5 SP1.

    I have 3 virtual machines as the following:

    - App-V Management Server (2012 R2) + IIS 8.5

    - App-V SQL Server 2012 SP1

    - App-V Publishing Server (2012 R2) + IIS 8.5

    I deleted the Default Website from the IIS and I am using Port 80 for the management, 81 for reporting and 82 for publishing server.

    The Publishing Server is installed on a separate Server.

    I can see all my published application in the App-V management Web.

    I have registered the App-V Publishing server under Servers TAB in the management Web as well.

    I noticed many events errors logged in the Publishing Server, Events ID: 214 & 215

    - Event ID214 @ The request URL doesn't contain the query string for the client version.

    - Event ID215 @ The request URL doesn't contain the query string for the client OS.

    If I browsed the Publishing Server URL, I can see all my published applications:

    - <Publishing Protocol="1.0">

    - <Packages>

     <Package PackageId="4711e502-bff3-4e38-a2f3-7c1f164cf2fc" VersionId="9fbd534c-d8ab-47da-b1c2-4540cd947fe0" PackageUrl="\\172.16.20.114\Content$\Computer Lab Apps\ActiveInspire.appv" />

     <Package PackageId="51461a66-3949-41ba-afc7-0d47752c9d9c" VersionId="a34dc5b3-bac7-49be-ae66-b255599e8064" PackageUrl="\\172.16.20.114\Content$\Office2010_x86_SP1\Office2010_x86_SP1_3.appv" />

    - <Package PackageId="d24c3bdd-8fad-44d3-998c-933f8f053682" VersionId="eb698da1-efa9-4545-beb9-f67cbb959f40" PackageUrl="\\172.16.20.114\Content$\Office365_x86\O365ProPlusRetail_en-us_x86.appv">

     <DeploymentConfiguration ConfigurationId="13" Path="policies_67/6/13" Timestamp="2013-11-12T05:46:23.41" />

     </Package>

     </Packages>

    - <NoGroup>

     <Package PackageId="4711e502-bff3-4e38-a2f3-7c1f164cf2fc" />

     <Package PackageId="51461a66-3949-41ba-afc7-0d47752c9d9c" />

     <Package PackageId="d24c3bdd-8fad-44d3-998c-933f8f053682" />

     </NoGroup>

     </Publishing>

    However, on the client side, the Error Log ID: 19104 is logged

    Part or all packages publish failed.

    published: 2

    failed: 1

    Please check the error events of 'Configure/Publish Package' before this message for the details of the failure.

    How can this be solved please?

    Your support is highly appreciated.

    Thank you.

  • Hi Arokiyaraj M,

    For the deployment configuration xml please use: Add-AppvClientPackage C:\pathto.appv -DynamicDeploymentConfiguration C:\pathtoxml

    For the user configuration xml please use: Publish-AppvClientPackage C:\pathto.appv -DynamicUserConfigurationPath C:\pathtoxml

    Hope that helps

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment