Psconfig wizard fails at 8th step when ran through GUI and when ran through command prompt fails at 4th step.

when we see in psconfig logs it does not have much information about the failure except the one to shown on the screen.

In upgrade.log we see huge bunch of information as

 

[SPManager] [DEBUG] [9/3/2009 9:04:05 PM]: [Microsoft.SharePoint.Administration.SPIisWebSite] Running 8 of 9 steps
[SPManager] [DEBUG] [9/3/2009 9:04:05 PM]: SPUpgradeJobDefinition progress update event: SPIisWebSiteWssSequence Upgrade Job 88% 8/9
[SPManager] [DEBUG] [9/3/2009 9:04:05 PM]: TotalTime 00:00:07.9841195, RefreshTime00:00:07.9841195
[WorkflowAuthorizedTypesFixUp] [3.1.2.0] [DEBUG] [9/3/2009 9:04:05 PM]: Begin Initialize()
[WorkflowAuthorizedTypesFixUp] [3.1.2.0] [DEBUG] [9/3/2009 9:04:05 PM]: End Initialize()
[WorkflowAuthorizedTypesFixUp] [3.1.2.0] [DEBUG] [9/3/2009 9:04:05 PM]: Begin Upgrade()
[WorkflowAuthorizedTypesFixUp] [3.1.2.0] [DEBUG] [9/3/2009 9:04:05 PM]: Application Web Config for this IIS site (1993797828) is found at C:\Inetpub\wwwroot\wss\VirtualDirectories\80\web.config.
[WorkflowAuthorizedTypesFixUp] [3.1.2.0] [DEBUG] [9/3/2009 9:04:05 PM]: End Upgrade()
[WorkflowAuthorizedTypesFixUp] [3.1.2.0] [DEBUG] [9/3/2009 9:04:05 PM]: Begin Commit()
[WorkflowAuthorizedTypesFixUp] [3.1.2.0] [DEBUG] [9/3/2009 9:04:05 PM]: End Commit()
[WorkflowAuthorizedTypesFixUp] [3.1.2.0] [DEBUG] [9/3/2009 9:04:05 PM]: Begin Dispose()
[WorkflowAuthorizedTypesFixUp] [3.1.2.0] [DEBUG] [9/3/2009 9:04:05 PM]: End Dispose()
[WorkflowAuthorizedTypesFixUp] [3.1.2.0] [DEBUG] [9/3/2009 9:04:05 PM]: Elapsed time: 00:00:00.0624980.
[SPManager] [DEBUG] [9/3/2009 9:04:05 PM]: [Microsoft.SharePoint.Administration.SPIisWebSite] Running 9 of 9 steps
[SPManager] [DEBUG] [9/3/2009 9:04:05 PM]: SPUpgradeJobDefinition progress update event: SPIisWebSiteWssSequence Upgrade Job 100% 9/9
[SPManager] [DEBUG] [9/3/2009 9:04:05 PM]: TotalTime 00:00:08.0622420, RefreshTime00:00:08.0622420
[EnableMemoryBasedAppPoolRecycling] [3.1.3.0] [DEBUG] [9/3/2009 9:04:05 PM]: Begin Initialize()
[EnableMemoryBasedAppPoolRecycling] [3.1.3.0] [DEBUG] [9/3/2009 9:04:05 PM]: End Initialize()
[EnableMemoryBasedAppPoolRecycling] [3.1.3.0] [DEBUG] [9/3/2009 9:04:05 PM]: Begin Upgrade()
[SPIisWebSiteWssSequence] [ERROR] [9/3/2009 9:04:05 PM]: Action 3.1.3.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed.
[SPIisWebSiteWssSequence] [ERROR] [9/3/2009 9:04:05 PM]: The system cannot find the path specified.

[SPIisWebSiteWssSequence] [ERROR] [9/3/2009 9:04:05 PM]:    at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
   at System.DirectoryServices.DirectoryEntry.Bind()
   at System.DirectoryServices.DirectoryEntry.get_AdsObject()
   at System.DirectoryServices.PropertyValueCollection.PopulateList()
   at System.DirectoryServices.PropertyValueCollection..ctor(DirectoryEntry entry, String propertyName)
   at System.DirectoryServices.PropertyCollection.get_Item(String propertyName)
   at Microsoft.SharePoint.Administration.SPIisApplicationPool.get_PeriodicRestartMemory()
   at Microsoft.SharePoint.Administration.SPProvisioningAssistant.EnableMemoryBasedAppPoolRecycling(SPIisApplicationPool local)
   at Microsoft.SharePoint.Administration.SPProvisioningAssistant.EnableMemoryBasedAppPoolRecycling(String applicationPoolId)
   at Microsoft.SharePoint.Upgrade.EnableMemoryBasedAppPoolRecycling.Upgrade()
   at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
[EnableMemoryBasedAppPoolRecycling] [3.1.3.0] [DEBUG] [9/3/2009 9:04:05 PM]: Begin Rollback()
[EnableMemoryBasedAppPoolRecycling] [3.1.3.0] [DEBUG] [9/3/2009 9:04:05 PM]: End Rollback()
[EnableMemoryBasedAppPoolRecycling] [3.1.3.0] [DEBUG] [9/3/2009 9:04:05 PM]: Begin Dispose()
[EnableMemoryBasedAppPoolRecycling] [3.1.3.0] [DEBUG] [9/3/2009 9:04:05 PM]: End Dispose()
[EnableMemoryBasedAppPoolRecycling] [3.1.3.0] [DEBUG] [9/3/2009 9:04:05 PM]: Elapsed time: 00:00:00.0312490.
[SPManager] [ERROR] [9/3/2009 9:04:05 PM]: Upgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed.
[SPManager] [ERROR] [9/3/2009 9:04:05 PM]: The system cannot find the path specified.

[SPManager] [ERROR] [9/3/2009 9:04:05 PM]:    at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
   at System.DirectoryServices.DirectoryEntry.Bind()
   at System.DirectoryServices.DirectoryEntry.get_AdsObject()
   at System.DirectoryServices.PropertyValueCollection.PopulateList()
   at System.DirectoryServices.PropertyValueCollection..ctor(DirectoryEntry entry, String propertyName)
   at System.DirectoryServices.PropertyCollection.get_Item(String propertyName)
   at Microsoft.SharePoint.Administration.SPIisApplicationPool.get_PeriodicRestartMemory()
   at Microsoft.SharePoint.Administration.SPProvisioningAssistant.EnableMemoryBasedAppPoolRecycling(SPIisApplicationPool local)
   at Microsoft.SharePoint.Administration.SPProvisioningAssistant.EnableMemoryBasedAppPoolRecycling(String applicationPoolId)
   at Microsoft.SharePoint.Upgrade.EnableMemoryBasedAppPoolRecycling.Upgrade()
   at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
[SPManager] [ERROR] [9/3/2009 9:04:06 PM]: Action 3.1.3.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed.
[SPManager] [ERROR] [9/3/2009 9:04:06 PM]:    at Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade()
   at Microsoft.SharePoint.Upgrade.SPManager.Upgrade(Object o, Boolean bRecurse)
[SPManager] [DEBUG] [9/3/2009 9:04:06 PM]: Elapsed time upgrading [Microsoft.SharePoint.Administration.SPIisWebSite]: 00:00:05.
[SPManager] [ERROR] [9/3/2009 9:04:06 PM]: ReflexiveUpgrade [Microsoft.SharePoint.Administration.SPIisWebSite] failed.
[SPManager] [ERROR] [9/3/2009 9:04:06 PM]: The system cannot find the path specified.

 

Why this happens :

 

Looking carefully in the logs we see psconfig first looked at

[WorkflowAuthorizedTypesFixUp] [3.1.2.0] [DEBUG] [9/3/2009 9:04:05 PM]: Application Web Config for this IIS site (1993797828) is found at C:\Inetpub\wwwroot\wss\VirtualDirectories\80\web.config.

and found the web.config and then the below error message

[SPIisWebSiteWssSequence] [ERROR] [9/3/2009 9:04:05 PM]: Action 3.1.3.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed. 

with path not found ..

[SPIisWebSiteWssSequence] [ERROR] [9/3/2009 9:04:05 PM]: The system cannot find the path specified.

further deep tells us something about app Pool.

at Microsoft.SharePoint.Administration.SPIisApplicationPool.get_PeriodicRestartMemory()
  

this is something which tells something is wrong on App Pool side.

To conclude…. we see this issue happening if App pool name is not the same as that we see under central administration->operations->service accounts section.

 

How to Fix it :-

 

As we know there is no way to rename the App pool to as it was and there is either no option in Central administration to do such things.

the best to resolve these issue will be to create a new copy of the app pool in IIS with the same name.

The main important point here is to make a duplicate copy, creating a new app pool with same name would not help here.

the steps to do so will be.

Open IIS manger – Application pool.

right Click the app pool – new – application pool

select the option “Use existing application pool template”

Application pool ID – use the name as that mentioned in services section.

 

there is no need to associate this app pool with the web application.

now run the psconfig GUI or command line it should complete successfully.