I want to provide a peek into some changes around Credential changes. We will be sending out further communications shortly.

Effective Dec 15, 2009, the following certifications will no longer be required for partners to qualify into the listed competencies.  The changes are in place now, Feb 2010.   Partners re-enrolling between Dec 15, 2009 and Feb 2010, will be provided manual overrides.

 Existing Competencies                                 Advanced Credentials to be Dropped

Systems Managent                                          MCSE

Server Platform                                                MCSE

Virtualization                                                     MCSE, MCITP

Security                                                                MCSE, Third Party Certs

Custom Development                                    MCTS, MCPD

Unified Communications (Messaging)    MCSE, MCITP

 

The reasoning is as follows:

  • The changes are Aligned with “Standard” competency requirements to be launched in Oct 2010
  • The “Advanced” credentials, as appropriate, will be applicable at “Advanced” competency level.  The "Advanced" competency requirements will be announced late this month (In Progress). 

 

I hope this clears up some confusion.  Again, MPN will be sending out communications shortly.  Please reach out to me with any questions.

 

Scott Akin

Regional Enablement Director

sakin@microsoft.com