There is a new page that has links and a FAQ explaining different language versions that are available.
 

Windows PowerShell 1.0 Release Candidate 2 currently supports Windows XP Service Pack 2 and Windows Server 2003. The .NET Framework 2.0 is required in order to install Windows PowerShell. Remember to download the Windows PowerShell Documentation Pack that includes a Getting Started Guide, Quick Reference chart and a 100+ page Windows PowerShell primer.

Windows PowerShell is supported on multiple platforms (x86, x64 & Itanium) and by multiple language technologies (English language, Localized and Multilingual User Interface).

Windows XP Service Pack 2

Platform

x86

English-Language Package for Windows XP

Localized Package for Windows XP

Multilingual User Interface (MUI) Package for Windows XP

x64

English-Language Package for Windows XP x64

Localized Package for Windows XP x64

Multilingual User Interface (MUI) Package for Windows XP x64

Windows Server 2003

Platform

x86

English-Language Package for Windows Server 2003 SP1

Localized Package for Windows Server 2003 SP1

Multilingual User Interface (MUI) Package for Windows Server 2003 SP1

x64

English-Language Package for Windows Server 2003 for x64

Localized Package for Windows Server 2003 for x64

Multilingual User Interface (MUI) Package for Windows Server 2003 x64

Itanium-based

English-Language Package for Windows Server 2003 SP1 for Itanium

Localized Package for Windows Server 2003 for SP1 Itanium

Multilingual User Interface (MUI) Package for Windows Server 2003 SP1 Itanium