I was recently putting together a demo lab for the latest public release of SCCM 2007 (Beta 2) and could not get past the following;

• MS06-030: Vulnerability in Server Message Block could allow elevation of privilege (http://go.microsoft.com/fwlink/?LinkId=79239).

• Windows Server 2003 Post-Service Pack 1 COM+ 1.5 Hotfix Rollup Package 6. Information about this Hotfix Rollup is available at: http://go.microsoft.com/fwlink/?LinkId=79240.

I am running Windows Server 2003 SP2 which addressed both of these issues,however the prerequisite checker during setup does not "know" what to do with SP2, so I was stuck.  I found some documentation on Setup Prerequisite Checks which includes good info on using the check in various senarios, but not how to get past it so I just tried the following  Setup /noprereq and I could complete the installation.

Obviously using this in normal setup without verifying that you meet all the requirements could cause issues, but if you want to run WS2003 SP2 until the SCCM 2007 Beta 2 setup has been changed to reflect those fixes, this is an option.