Tim McMichael

Navigating the world of high availability...

‘ClusteredMailboxServer’ is partially configured – ExBPA.

‘ClusteredMailboxServer’ is partially configured – ExBPA.

  • Comments 1
  • Likes

When running ExBPA against an Exchange 2007 cluster, the following error text may be noted:

===========================================================

Error: 'ClusteredMailboxServer' is partially configured

Server: <SERVER>

'ClusteredMailboxServer' is partially configured on server <SERVER>.contoso.com. Either setup is configuring it right now or setup failed while configuring it. Please rerun setup if it isn't currently running.

===========================================================

The link text from ExBPA advises users on how to correct this issue:

===========================================================

Possible CMS Setup Failure  Send Feedback

Microsoft Exchange Server Analyzer - Articles > Exchange Cluster

Topic Last Modified: 2008-04-01

The Microsoft® Exchange Server Analyzer Tool reads the following registry branch for the presence of the Action or Watermark registry values:

HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\v8.0\ClusteredMailboxServer

If the Exchange Server Analyzer finds that either the Action or Watermark registry values are present, an error is displayed.

The presence of the Action or Watermark registry values on this registry branch indicates that either there was a previously unsuccessful installation of the Cluster Mailbox Server (CMS) to the cluster node, or that the CMS installation was in progress when the Exchange Server Analyzer was doing its analysis.

If the CMS installation failed on this node but was successful on other nodes of the cluster, it could appear that the cluster network is functioning normally when that is not the case.

To address this error, determine whether CMS installation is still in progress on the affected node and, if not, rerun setup to complete the failed CMS installation.

===========================================================

One of the ExBPA rules checks the registry to find out the install state of roles on the server.  Exchange 2007 uses watermark keys to track setup progress.  If a failure is encountered during setup, when setup is rerun the watermark is consulted and setup resumed at or near the point of failure.  When setup completes successfully the watermark value is cleared.

The following is a sample export of a clustered server mailbox role watermark.

===========================================================

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\ClusteredMailboxServer]
"Action"="Install"
"Watermark"=dword:7448a073

===========================================================

It is not uncommon to see this rule triggered against clustered nodes – especially if there at one point was a setup failure.  Sometimes during installation when a failure is encountered and the clustered mailbox server is partially configured the resources created will be moved between nodes.  Setup is then run on the other node in hopes that it will complete successfully.  In some cases it will complete successfully and in other cases it will fail. 

The watermark is not checkpointed / replicated between the registry of the nodes.  In the event that setup fails each node will have a watermark indicating the point in the installation where the failure occurred.  Should one of the nodes complete setup successfully, one node will have it’s watermark cleared while the other retains the watermark. 

The presence of this key triggers the ExBPA rule.

In order to tell what actions need to be taken we must first determine if installation completed successfully.  For this we can turn to the Exchange setup logs that are created on each node.  We will review the logs and see if it can be determined if setup completed successfully.

The setup logs are located at c:\ExchangeSetupLogs.

We are looking for the file ExchangeSetup.log.  This file can be opened in a text viewer.

If the following text can be found in the setup log it should be safe to assume that setup completed successfully for that CMS on at least one of the nodes.

The start of the clustered mailbox server installation is indicated in the logs by the following series of text (or similar depending on single copy cluster or cluster continuous replication installation):

===========================================================

<DATE> [0] Setup will run the task 'new-ClusteredMailboxServer'
<DATE> [1] Setup launched task 'new-ClusteredMailboxServer -DomainController DC' -PublicFolderDatabase $false -updatesdir 'Y:\x64\Updates' -Name <CMSNAME> -IPAddress <IPAddress> -IPv4Addresses $null -IPv4Networks $null -IPv6Networks $null -SharedStorage $false -DataPath <DATAPATH>

===========================================================

If you continue to scroll through the log and reach the following text the setup command completed successfully.

===========================================================

<DATE> [0] The Microsoft Exchange Server setup operation completed successfully.
<DATE> [0] End of Setup

===========================================================

Once you have verified that the command was run and completed successfully, the watermark can be exported and safely removed using registry editor.

If for any reason you cannot verify that setup finished for this CMS instance on at least one of the nodes, the only safe procedure for removing the watermark is to allow setup to complete successfully.  (This needs to occur even if the resources are already online and even if they are servicing users).

If you have the setup log this can be an easy task.  The parameters that were used for setup are also logged in this log.  The following line will tell you what parameters were used when establishing the clustered mailbox server installation. 

<DATE> [0] ExSetup was started with the following command: '/NoLogo /newCMS /cmsName:2003-MBX3 /cmsIPAddress:192.168.0.14 /sourcedir:Y:\x64 /FromSetup'.

In this case you can see that the CMSName parameter used is 2003-MBX3, the CMSIpaddress is 192.168.0.4.  No additional switches (like CSS and CMSDataPath) indicate this was a CCR installation.

If you do not have the setup log you will most likely need to use cluster administrator to get the necessary information.  Using cluster administrator locate the CMS Network Name resource and CMS IPv4 Resource.  Make note of the values of each of these resources.

Once you have the values necessary to complete the command the CMS must be moved to the node where the watermark exists.  If the CMS is not currently on that node, issue a move-clusteredmailboxserver using the Exchange Management Shell. 

Once the CMS has been moved to the node with the watermark, run setup using the command line setup with  appropriate values.  Using my example above:

setup.com /newCMS /cmsName:2003-MBX3 /cmsIPAddress:192.168.0.4

Setup will consult the watermark on the machine and when it completes successfully clear the watermark value.  This will ensure that the CMS is now fully configured to support Exchange.

Comments
  • thanks, very nice post. you saved me from a complete demotion of ccr :)

    i would like to add that our exchanges setup logs didnt have

    <DATE> [0] The Microsoft Exchange Server setup operation completed successfully.

    <DATE> [0] End of Setup

    instead it was a failure on the setup

    still the watermark was present on the active node ,and system attendant wont start.

    after

    setup.com /newCMS

    everything was stabilised and the copy process returned to healthy.

    thanks

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment