Thomas Ellermanns view on System Center

This blog will discuss features, functions and views on Operations Manager and Service Manager

SCSM Portal error, due to Web Content Server being out of sync

SCSM Portal error, due to Web Content Server being out of sync

  • Comments 4
  • Likes

Recently one of my customers had issues with their SCSM Portal where new categories didn't appear and several of the Request offerings failed.

 

Looking in the SMPortalTrace.log it stated that a Management pack was missing from system:

Ressourcestrings for troubleshooting is not available. Keys and arguments often contains enough information to start the troubleshooting a problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.0.10411.00&File=mscorlib.dll&Key=Arg_TargetInvocationException ---> Microsoft.EnterpriseManagement.Presentation.DataAccess.DataAccessConverterException: Microsoft.EnterpriseManagement.Presentation.DataAccess.DataAccessConverterException: An error occurred during a results conversion using type: Microsoft.EnterpriseManagement.ServiceManager.Portal.DataProviders.RequestOfferingOutputConverter ---> Microsoft.EnterpriseManagement.Common.InconsistentDataException: The requested objects had an unknown management pack. ---> Microsoft.EnterpriseManagement.Common.InconsistentDataException: The call produced inconsistent results. The data on the client does not match the data returned from the server. The most likely cause is that client-side cache is out of sync with server data. ---> Microsoft.EnterpriseManagement.Common.ObjectNotFoundException: An object of class ManagementPack with ID 40b87bdd-608a-8858-9ada-e6de1ee8ed9f was not found.

See this blog post on where to the find the SMPortalTrace.log

Looking in the SCSM database the management pack missing is actually the MP containing the offering and is therefore not missing. Do this to check if the MP is in the database: SELECT * FROM ManagementPack WHERE ManagementPackID = ‘40b87bdd-608a-8858-9ada-e6de1ee8ed9f’

But looking at the line just above, there is a message about client-side cache being out of sync:

Microsoft.EnterpriseManagement.Common.InconsistentDataException: The call produced inconsistent results. The data on the client does not match the data returned from the server. The most likely cause is that client-side cache is out of sync with server data.

Since my customer is using a corporate SharePoint farm, the Web Content Server (WCS) is on a dedicated server. I therefore uninstalled the WCS and installed it again. After that the portal worked..

If you have this problem, maybe a simple restart of the application pools is enough, otherwise reinstall is the way to go.

 

Thanks to Ruth Lilly from Microsoft Support for helping with the troubleshooting.

 

 

Comments
  • You might be able to get away with a simple refresh (ctrl + F5) of the portal.  There is a known issue with a similar (if not the same) error as this, and the solution is to refresh using ctrl + F5 to reload the page.  I'm just not sure if this is the exact error or not, but you might want to give it a shot if you see this again.

  • I have faced the same, Solution is Just Reset Internet Explorer or Reset IIS or Refresh WebPage

  • I too had a similar issue and I simply restarted the "WebContent" and "SMPortal" sites on Sharepoint and everything was working again. -weird

  • Recycling both application pools should do it. No need to reset the site (atleast try recycling first).

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment