We are seeing a few cases where the VBA component of the Office 2013 apps stop functioning.  The applications are working properly when installed.  Then a few days later VBA buttons no longer work.  Here are the scenarios that we
have seen:

Access:

  • When running wizards the receive the following error,  “This feature isn't installed, or has been disabled"
  • When opening VBA editor the user receives “Microsoft Access is unable to load the Visual Basic for Applications dynamic-link library (dll) Vbe7" when opening the Visual Basic Editor (VBE)”

Excel

  • The Visual Basic, Macros and Record Macro options are disabled/greyed on the ribbon.
  • When opening workbooks with VBA code, the user receive the following message, “The Visual Basic for Applications (VBA) macros in this workbook are corrupted and have been deleted."

Word

  • The Macro button is not greyed out but when trying to run or record a macro they receive the following
    message, “The function you are attempting to run contains macros or content that requires macro language support"


PowerPoint

  • The Visual Basic, and Macros options are disabled/greyed on the ribbon.
  • When opening presentations with VBA code, the user receive the following message:
    "The document contains macros. Macro language support for this application is disabled.  Features requiring VBA are not available. Would you like to open this document read-only?"

 

In most cases repairing MS Office fixes the issue.   

What we believe is happening is there is a registry cleaner or system maintenance type application removing some our registry keys that we
need for VBA to run successfully.  In the above scenarios when the MS Office application was installed the VBA worked properly.