Troubleshooting SCCM ..Part I (Client Push Installation )

Troubleshooting SCCM ..Part I (Client Push Installation )

  • Comments 12
  • Likes

Client Installation

 

Once you are through with the installation of the SCCM server and the configuration then the next major task is client or agent installation. There are various methods to accomplish this task. Please check this link for more details.  http://technet.microsoft.com/en-us/library/bb633063.aspx

 e,

Whatever be the method used, the logic remains the same. The ccmsetup.exe is downloaded to the system and is executed. The ccmsetup.exe reads the manifest file and fetches the remaining files to continue the client installation.

 

When ccmsetup.exe runs from the source specified in the command or from the MP it will download the other necessary files required for installation and trigger the client installation on the local system

 

The important log in case of client installation in the agent is the ccmsetup.log and clientmsi.log these logs are present in the location C:\windows\System32\ccmsetup

 

Troubleshooting Client Push Installation

 

When we start troubleshooting client push installation the first log we need to check is ccm.log in the server logs [1] .If you look at the ccm.log you can see the start of the request made to the client and you can verify if the ccmsetup.exe service was able to successfully run on the targeted client machine.

 

èCCM.log

 

Received request: "HIQMYRJC" for machine name: "SQL" on queue: "Incoming".        SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:37 AM  1908 (0x0774)

Stored request "HIQMYRJC", machine name "SQL", in queue "Processing".                   SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:37 AM  1908 (0x0774)

======>Begin Processing request: "HIQMYRJC", machine name: "SQL"  SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:40 AM  3196 (0x0C7C)

---> Attempting to connect to administrative share '\\SQL.MYLAB.IN\admin$' using account 'mylab\administrator'              SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:40 AM  3196 (0x0C7C)

---> Connected to administrative share on machine SQL.MYLAB.IN using account 'mylab\administrator'            SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:43 AM  3196 (0x0C7C)

---> Attempting to make IPC connection to share <\\SQL.MYLAB.IN\IPC$>                      SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:43 AM  3196 (0x0C7C)

---> Searching for SMSClientInstall.* under '\\SQL.MYLAB.IN\admin$\'   SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:43 AM  3196 (0x0C7C)

---> Service Pack version from machine "SQL" is 2                     SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:49 AM  3196 (0x0C7C)

---> Creating \ VerifyingCopying exsistance of destination directory \\SQL\admin$\system32\ccmsetup.          SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:50 AM  3196 (0x0C7C)

---> Copying client files to \\SQL\admin$\system32\ccmsetup.                     SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:50 AM  3196 (0x0C7C)

---> Copying file "C:\Program Files\Microsoft Configuration Manager\bin\I386\MobileClient.tcf" to "\\SQL\admin$\system32\ccmsetup\MobileClient.tcf"                        SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:50 AM  3196 (0x0C7C)

---> Copying file "C:\Program Files\Microsoft Configuration Manager\bin\I386\ccmsetup.exe" to "\\SQL\admin$\system32\ccmsetup\ccmsetup.exe"                        SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:50 AM  3196 (0x0C7C)

---> Created service "ccmsetup" on machine "SQL".                  SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:31:55 AM  3196 (0x0C7C)

---> Started service "ccmsetup" on machine "SQL".                   SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:32:02 AM  3196 (0x0C7C)

---> Deleting SMS Client Install Lock File '\\SQL.MYLAB.IN\admin$\SMSClientInstall.LAB'                 SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:32:02 AM  3196 (0x0C7C)

---> Completed request "HIQMYRJC", machine name "SQL". SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:32:02 AM  3196 (0x0C7C)

Deleted request "HIQMYRJC", machine name "SQL"                 SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:32:02 AM  3196 (0x0C7C)

<======End request: "HIQMYRJC", machine name: "SQL".   SMS_CLIENT_CONFIG_MANAGER    4/16/2010 9:32:02 AM  3196 (0x0C7C)

 

If you are able to see that the ccmsetup.exe service is created then it clearly informs us that the server has completed its request to the client and the client has started installing.  From here on you need to check the client for troubleshooting.

 

In case you don’t see “started service” in ccm.log then that means that the requirements are not met. See the points below for the Client Push installation pre-requisites

 

·         At least one Client Push Installation account must be defined in the Accounts tab of the Client Push Installation Properties dialog box. This account must be a member of the local Administrators group.

·         The computer to which you are targeting the client installation must have been discovered by at least one Configuration Manager 2007 discovery method.

·         The computer has an ADMIN$ share and able to connect from the SCCM server with the account used for Client push installation (You can check if you can access \\<Clientname>\ADMIN$ from the sccm server)

  •  
    • In case this fails make sure that  ADMIN$ is enabled in the client
    • From the server to the client there are no DNS issue
    • Firewall is not blocking the SMB traffic
    • Account Specified for client push is correct and have permission to connect to the share

·         The WMI connection also should be possible from the SCCM server to the client with the account used for Client push installation  (You can use WbemTest and try connecting to \\<Clientname>\root\cimv2 and make sure you are able to remotely connect to client WMI)

  •  
    • Make sure that there are no DNS issues
    • Check the properties of the WMI and make sure remote connectivity is allowed
    • Make sure the RPC port 135 and the Dynamic port range is opened in any firewall between the client and the server including the windows firewall.

·         Enable client push installation to assigned resources must be selected in the Client Push Installation Properties dialog box if you want to automatically push the Configuration Manager 2007 client to discovered resources.

·         The client computer must be able to contact a management point in order to download supporting files.

·         The ports used when you are doing a client push is

Description

UDP

TCP

Server Message Block (SMB) between the site server and client computer.

--

445

RPC endpoint mapper between the site server and the client computer.

135

135

RPC dynamic ports between the site server and the client computer.

--

DYNAMIC

Hypertext Transfer Protocol (HTTP) from the client computer to a mixed mode management point.

--

80 (See note 1, Alternate Port Available)

Secure Hypertext Transfer Protocol (HTTPS) from the client computer to a native mode management point.

--

443 (See note 1, Alternate Port Available)

 

·         In order to successfully use client push to install the Configuration Manager 2007 client, you must add the following as exceptions to the Windows Firewall:

 

  •  
    • File and Printer Sharing
    • Windows Management Instrumentation (WMI)

 

The following links will give more details

http://technet.microsoft.com/en-us/library/bb680537.aspx

http://technet.microsoft.com/en-us/library/ff189805.aspx

http://technet.microsoft.com/en-us/library/bb694088.aspx

 

Client side troubleshooting

 

Once the ccmsetup service is started in the client then you need to check the client logs. If you look at the ccmsetup.log you should find that from the source or the MP the required files are downloaded. If you find any error pertaining to download please check the following

 

1)      There is no DNS issue in the client and that client is able to resolve the SCCM server NetBIOS as well as FQDN without any issues.

2)      Make sure that the MP link is accessible from the client

http://<SCCM_SERVER/SMS_MP/.sms_aut?mplist

http://<SCCM_SERVER/SMS_MP/.sms_aut?mpcert

If the above test fails make sure that MP is working fine. You can check mpcontrol.log on the server to find the error and make sure that the same works.

3)      Make sure that the firewall allows the download of the required files.

 

è CCMSETUP.log

==========[ ccmsetup started in process 5780 ]==========                       ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

Version: 4.0.6487.2000                         ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

Command line parameters for ccmsetup have been specified.  No registry lookup for command line parameters is required.                  ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

Command line: "C:\WINDOWS\system32\ccmsetup\ccmsetup.exe" /runservice /config:MobileClient.tcf        ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

CCMHTTPPORT:    80       ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

CCMHTTPSPORT:    443  ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

CCMHTTPSSTATE:    0     ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

CCMHTTPSCERTNAME:                         ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

FSP:               ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

CCMFIRSTCERT:    0         ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

Config file:      C:\WINDOWS\system32\ccmsetup\MobileClient.tcf             ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

Retry time:       10 minute(s)                  ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

MSI log file:                        ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

MSI properties:    INSTALL="ALL" SMSSITECODE="LAB" CCMHTTPPORT="80" CCMHTTPSPORT="443" CCMHTTPSSTATE="0" CCMFIRSTCERT="0"                       ccmsetup     1/31/2010 8:55:52 AM                 5100 (0x13EC)

Source List: ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

                  \\SCCM.MYLAB.IN\SMSClient                  ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

                  \\SCCM\SMSClient                ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

MPs:              ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

                  SCCM.MYLAB.IN                    ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

Updated security on object C:\WINDOWS\system32\ccmsetup\.                ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

A Fallback Status Point has not been specified.  Message with STATEID='100' will not be sent.        ccmsetup     1/31/2010 8:55:52 AM  5100 (0x13EC)

Running as user "SYSTEM"                   ccmsetup     1/31/2010 8:55:52 AM  4928 (0x1340)

Detected 2442 MB free disk space on system drive.                  ccmsetup     1/31/2010 8:55:52 AM  4928 (0x1340)

DetectWindowsEmbeddedFBWF() Detecting OS Version         ccmsetup     1/31/2010 8:55:52 AM  4928 (0x1340)

Client OS Version is 5.2, Service Pack Version 2  ccmsetup     1/31/2010 8:55:52 AM  4928 (0x1340)

Client OS is not a supported Windows Embedded Platform     ccmsetup     1/31/2010 8:55:52 AM  4928 (0x1340)

IsFileMicrosoftTrusted Verified file 'C:\WINDOWS\system32\ccmsetup\WindowsServer2003-KB923845-x86-ENU.exe' is MS signed.                        ccmsetup     1/31/2010 8:56:32 AM  4928 (0x1340)

Installing file 'C:\WINDOWS\system32\ccmsetup\WindowsServer2003-KB923845-x86-ENU.exe' with options '/norestart /quiet /log:C:\WINDOWS\system32\ccmsetup\WindowsServer2003-KB923845-x86-ENU.exe.log'.         ccmsetup     1/31/2010 8:56:32 AM  4928 (0x1340)

File 'C:\WINDOWS\system32\ccmsetup\WindowsServer2003-KB923845-x86-ENU.exe' returned exit code 3010.                ccmsetup     1/31/2010 8:58:18 AM  4928 (0x1340)

Finished installing file 'C:\WINDOWS\system32\ccmsetup\WindowsServer2003-KB923845-x86-ENU.exe'.      ccmsetup     1/31/2010 8:58:18 AM  4928 (0x1340)

Successfully ran BITS check.                ccmsetup     1/31/2010 8:58:18 AM  4928 (0x1340)

IsFileMicrosoftTrusted Verified file 'C:\WINDOWS\system32\ccmsetup\ccmsetup.cab' is MS signed.                ccmsetup     1/31/2010 8:58:48 AM  4928 (0x1340)

Successfully extracted manifest file C:\WINDOWS\system32\ccmsetup\ccmsetup.xml from file C:\WINDOWS\system32\ccmsetup\ccmsetup.cab.                    ccmsetup     1/31/2010 8:58:48 AM                 4928 (0x1340)

Loading manifest file: C:\WINDOWS\system32\ccmsetup\ccmsetup.xml                        ccmsetup     1/31/2010 8:58:48 AM  4928 (0x1340)

Successfully loaded ccmsetup manifest file.           ccmsetup     1/31/2010 8:58:48 AM  4928 (0x1340)

 

 

Once the download is over the MSI action starts and the client installation proceeds so further error shown you need to check the client.msi.log to see if there is issue.

 

 

èClient.msi.log

 

=== Verbose logging started: 4/16/2010  9:36:44  Build type: SHIP UNICODE 3.01.4000.3959  Calling process: C:\WINDOWS\system32\ccmsetup\ccmsetup.exe ===

MSI (c) (8C:48) [09:36:45:817]: Resetting cached policy values

MSI (c) (8C:48) [09:36:45:817]: Machine policy value 'Debug' is 0

MSI (c) (8C:48) [09:36:45:817]: ******* RunEngine:

           ******* Product: C:\WINDOWS\system32\ccmsetup\{4CD82FBB-0AFC-4864-A089-15364DF5F14B}\client.msi

           ******* Action:

           ******* CommandLine: **********

MSI (c) (8C:48) [09:36:45:927]: Client-side and UI is none or basic: Running entire install on the server.

MSI (c) (8C:48) [09:36:45:927]: Grabbed execution mutex.

MSI (c) (8C:48) [09:36:45:957]: Cloaking enabled.

MSI (c) (8C:48) [09:36:45:957]: Attempting to enable all disabled priveleges before calling Install on Server

MSI (c) (8C:48) [09:36:45:957]: Incrementing counter to disable shutdown. Counter after increment: 0

………………… (Proceeds………………)

……………………..

Property(S): PrimaryVolumePath = C:

MSI (s) (78:74) [10:05:05:310]: Note: 1: 1728

MSI (s) (78:74) [10:05:05:350]: Product: Configuration Manager Client -- Configuration completed successfully.

 

MSI (s) (78:74) [10:05:05:530]: Cleaning up uninstalled install packages, if any exist

MSI (s) (78:74) [10:05:05:530]: MainEngineThread is returning 0

MSI (s) (78:74) [10:05:05:630]: Destroying RemoteAPI object.

MSI (s) (78:C8) [10:05:05:670]: Custom Action Manager thread ending.

=== Logging stopped: 4/16/2010  10:05:05 ===

MSI (c) (8C:48) [10:05:06:321]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1

MSI (c) (8C:48) [10:05:06:391]: MainEngineThread is returning 0

=== Verbose logging stopped: 4/16/2010  10:05:06 ===

 

 

Common issue found at this phase is the WMI issues of the client. You can try rebuilding the WMI or can fix that before you retry the installation. More details on this you can check the client reporting troubleshooting.

 

Note: Rebuilding WMI might lead to some application which were working on the system not to work so make sure you don’t perform this on servers but can be done on client OS where you can reinstall the application not working after the rebuild.

 

Once successfully completed you should find

 

èCCMSETUP.LOG

MSI: Action 9:50:05: RollbackCleanup. Removing backup files                      ccmsetup     4/16/2010 9:50:05 AM  5336 (0x14D8)

MSI: Action 9:50:08: RemoveExistingProducts. Removing applications      ccmsetup     4/16/2010 9:50:08 AM  5336 (0x14D8)

Installation succeeded. Windows Installer has requested a reboot.             ccmsetup     4/16/2010 9:50:08 AM  5336 (0x14D8)

Successfully deleted the ccmsetup service             ccmsetup     4/16/2010 9:50:15 AM  5336 (0x14D8)

A Fallback Status Point has not been specified.  Message with STATEID='401' will not be sent.        ccmsetup     4/16/2010 9:50:15 AM  5336 (0x14D8)

Deleted file C:\WINDOWS\system32\ccmsetup\WindowsServer2003-KB923845-x86-ENU.exe     ccmsetup     4/16/2010 9:50:15 AM  2032 (0x07F0)

Deleted file C:\WINDOWS\system32\ccmsetup\ccmsetup.cab                    ccmsetup     4/16/2010 9:50:15 AM  2032 (0x07F0)

Deleted file C:\WINDOWS\system32\ccmsetup\ccmsetup.xml                    ccmsetup     4/16/2010 9:50:15 AM  2032 (0x07F0)

Deleted file C:\WINDOWS\system32\ccmsetup\client.msi     ccmsetup     4/16/2010 9:50:15 AM  2032 (0x07F0)

 

 

If you are using the Software Update Point client installation you can check the windowsupdate.log on %systemdrive%\windows\. On checking this log you will be able to find that the installation request is forward as a mandatory update and this triggers the ccmsetup.log

 

If you are using the logon script or group policy you need to make sure that the group policy is applied successfully to that system and after that you need to check the usual ccmsetup.log and client.msi.log

 

For manual installation you can check the same log and see the process ccmsetup.log and client.msi.log

 

Few Related links which will be of help.

 

Data Flows for Configuration Manager Client Deployment : http://technet.microsoft.com/en-us/library/bb680591.aspx

Troubleshooting Configuration Manager Client Deployment: http://technet.microsoft.com/en-us/library/bb693607.aspx

Planning for Configuration Manager Client Deployment : http://technet.microsoft.com/en-us/library/bb693966.aspx

Configuring Configuration Manager Client Deployment : http://technet.microsoft.com/en-us/library/bb680326.aspx   

Tasks for Configuration Manager Client Deployment : http://technet.microsoft.com/en-us/library/bb680606.aspx 

Technical Reference for Configuration Manager Client Deployment : http://technet.microsoft.com/en-us/library/bb694109.aspx

Client Reporting

Sometimes the most challenging part of the Configuration Manager 2007/SMS 2003 deployment phase can be ensuring that the client successfully reports to the site server. We occasionally see these issues here in support, typically either as cases for clients not reporting after the client installation, or maybe where it’s noticed that the client count is decreasing from the collection.

When we look at the SMS/SCCM console collection, there is an entry for the client status that indicates either Yes or No. Assuming everything is installed and configured properly, a client installed on a system should automatically report as Yes, but sometimes that does not turn out to be the case. The reason could be that the client has not yet reported to the SCCM\SMS server, or it was reporting previously but has now stopped. Managing the client in the collection is a continuous task and for a healthy environment the client should be continuously reporting to the SMS\SCCM server.

Troubleshooting issues where clients are not reporting

You can have a look at this blog for more details

http://blogs.technet.com/configurationmgr/archive/2009/08/10/troubleshooting-issues-where-clients-are-not-reporting.aspx



[1] Server logs   <Drive>:\Program Files\Microsoft Configuration Manager\Logs  or <Drive>\SMS\Logs

Comments
  • This phrase:

    The important log in case of client installation in the agent is the ccmsetup.log and clientmsi.log these logs are present in the location C:\windows\System32

    should be:

    The important log in case of client installation in the agent is the ccmsetup.log and clientmsi.log these logs are present in the location C:\windows\System32\ccmsetup

  • Point noted and corrected as well ,,, Thanks

  • The configuration Manager Client installs on the client just fine, however under the General Tab in Site Mode it says Unknow and should be Mixed. Any ideas?

  • i think your client is not yet registered..Check the in the advanced tab whether the site code is there or not....??/

  • hi

    i have use 2003 server with Service pact 2 then installed sccm 2007 with service pach 1 after that i have installed pust client throught sccm 2007 but not install client on all machine i have checked their are some error

    WMI R remote error is that please help me  

  • After client installation, there is a one exe will be running continuously, what is that?

  • Hi,

    I need help in writing Powershell script for client Push installation on Resource...??

  • ...this helped a lot...fantastic!

  • Can anyone suggest me the Best training institute to get trained in SCCM in Hyderabad

  • I cannot believe I spent this much time on troubleshooting this R2 upgrade. We had a tech leave and so we had to change the admin password at the same time. Wouldn't you know I forgot to change it. Thanks man this helped. · At least one Client Push Installation account must be defined in the Accounts tab of the Client Push Installation Properties dialog box. This account must be a member of the local Administrators group.

  • Hi everyone,
    I find out what whas the problem using CMTrace tools from Tools directory of SCCM server share. Opening CCM.log and realize there was problem with client connection. Then, checking in Administration -> Security -> Account -> Client Push Installation Account and there was a .. Wrong Password. The Account didn't have the rights to install anything on clients simply because I mistyped the password!
    Hope this can help you too!

  • Hi everyone,
    I find out what whas the problem using CMTrace tools from Tools directory of SCCM server share. Opening CCM.log and realize there was problem with client connection. Then, checking in Administration -> Security -> Account -> Client Push Installation Account and there was a .. Wrong Password. The Account didn't have the rights to install anything on clients simply because I mistyped the password!
    Hope this can help you too!

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment