Unable to Open the SCCM CONSOLE

Unable to Open the SCCM CONSOLE

  • Comments 4
  • Likes


We had issues in which when we try to Open the SCCM CONSOLE we were getting the

Error message
============
"The ConfigMgr console could not connect to the ConfigMgr site database. Verify that this computer has network connectivity to the SMS Provider computer and that your user account has Remote Activation permissions on both the ConfigMgr site
server and SMS Provider computers. For more information, see "How to Configure DCOM Permissions for Configuration Manager Console Connections" in ConfigMgr Help"

On the SMSADMINUI.log you will have the following information


SMSADMINUI.log
=============
Error Code:
InvalidClass
\r\nSystem.Management.ManagementException\r\nInvalid class \r\n at
System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus
errorCode)
at
System.Management.ManagementObjectCollection.ManagementObjectEnumerator.MoveNext()

at
Microsoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlQueryResultsO
bject.<GetEnumerator>d__0.MoveNext()\r\nManagementException details:
instance of __ExtendedStatus
{
Operation = "ExecQuery";
ParameterInfo = "SELECT * FROM SMS_Site WHERE
ReportingSiteCode = ''";
ProviderName = "WinMgmt";
};
\r\n
[4][8/8/2008 1:09:29 PM] :Failure while loading required 'WQL' query engine, console cannot connec

Troubleshooting

=============

For troubleshooting this issue

·         Go to start ->run -> Wbemtest

·         Cick to Connect to root\sms --> Enum Classes-->Select recursive- -->Select
SMS_ProviderLocation () Click on instances

·         In case you find that there was no entry for this, Please re-compile smsprov.mof using the command mofcomp smsprov.mof

 

Note: if mofcomp has to run the path needs to be set to C:\Windows\System32\wbem. SMSprov.mof will be inside the bin folder where you had installed the SCCM \program files\Microsoft Configuration Manager\bin\i386

 

 

Hope this information will be useful

 

Sudheesh Narayanaswamy | Support Engineer

Comments
  • Thanks, very helpfull! This solutions was resolve my problem.

  • Its very helpful.... Me too copied the same in my blog. Thanks....

  • Hi guys

    Thanks, fix our problem to, Do you know Why this problem appear ? We push some update lately, do you know if its related ?

  • if that update has to do something with WMI it is expected

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment