I know this is nothing to do with Microsoft but as an IT Pro myself I'd like to help others waste time trying to find the Vista drivers for the T-mobile 3G web'n'walk data card. I've recently rebuilt my machine hence need the Vista drivers for my 3G card and as it's taken me ages to find them (again) I figured I'm probably not the only one trying to find them. The complication is that the t-mobile site offers "downloads" for content AND it also provides advice for car "drivers" too so most of the searches I tried were hopeless.

You can find the Vista drivers here.

Note: Both the device and drivers work well on x86 (32 bit) Windows Vista. They exhibit really weird behaviour on x64 though. The client software "T-mobile Communications Centre (TMCC)" installs successfully as do the drivers according to the messages displayed during the installation. Post installation you have to reboot and then start TMCC to connect to the 3G network. The software starts and appears to communicate with the data card though it fails to find a 3G signal. Dual booting into 32 bit Vista while in the same physical location I get a good signal. I suspect that the software kit doesn't include 64-bit drivers and that the client software doesn't error trap this hence appears to work.

BTW: The installation program states that it may take 5 minutes to complete - bear this in mind as they progress indicator stopped moving all together at about 20% progress for several minutes on my system then came back to life and successfully completed the installation.