Wie ihr sicher alle wisst bin ich verantwortlich für das Backend der “Group Policy Search” (GPS). Dieses läuft auf Windows Azure und ist als “einfacher” WebService implementiert.

Ursprünglich lief das Ganze mal auf einem IIS 7 mit SQL Server 2008 und wurde dann vor über 2 Jahren (19.4.2010) auf Windows Azure portiert (hat im Übrigen einen Nachmittag gedauert, incl. DB Migration!).

Damals haben wir .NET 3.5 verwendet und damit läuft es noch heute (mal gucken, irgendwann werden wir auch das sicher mal anpassen, aber darum soll es heute hier nicht gehen.)

Da wir nun auch bei anderen Produkten nicht stehengeblieben sind, sind mittlerweile meine Systeme vollständig auf die neuesten Versionen upgegraded. Dies brachte ein paar Probleme bei der Wartung der GPS mit sich, denn das Azure SDK war nicht sofort verfügbar (ist es jetzt!!!), so dass ich die Vorbereitungen für die Erweiterung der GPS mit den neuen Policies etwas schieben musst.

Dies hat sich nun geändert und so wollte ich gleich frisch ans Werk gehen, also VS2012 mit Azure SDK 1.7 SP 1 gestartet, mein Projekt ausgewählt und in freudiger Erwartung F5 gedrückt.

Was ich dann sah war unerwartet, nämlich eine schlichte HTTP500 Server error Meldung, egal was ich ansurfte – also auch eine simple Hello-World.html blieb bei 500.

Der IIS lief eigentlich so, wie ich mir das vorstellte, meine direkt, also nicht über die Azure Instanz, aufgerufene hello-world.html tat was sie sollte und – vielleicht lag es an der Hitze – ich war erst mal ratlos.

Allerdings machte mich sehr stutzig, dass weder HTML noch sonst irgend etwas funktionierte, vom Debugging mal ganz zu schweigen.

Meine Vermutung war dann, dass etwas mit dem IIS nicht passte, denn alles andere lief und tat wie gewünscht.

Also über den Rechtsklick auf den Startbutton “Programme und Features” ausgewählt und die Windows Features angeklickt:

image

Sah eigentlich alles ganz normal aus, jedoch gehört ASP.NET wohl nicht mehr zum Default Setting, denn ein Klick weiter sah das Ganze so aus:

image

Nachdem ich das ASP.NET 3.5 Feature aktivierte (natürlich habe ich auch gleich 4.5 mitgenommen, die GPS soll ja irgendwann mal upgegraded werden) funktionierte meine lokale Testumgebung wieder wie gewohnt.

 

Viel Spaß also mit den neuen Tools und dem Windows Azure SDK 1.7SP1 für Visual Studio 2012.

 

-Stephanus

 

P.S.: natürlich muß für ASP.NET 3.5 auch das Windows Feature .NET Framework 3.5 aktiviert sein!

image

P.P.S.: Ich habe noch kein Release Datum für die neuen Policies, aber keine Sorge, spätestens am 26.10.2012 sollten diese auch in der GPS live sein!