Stefan Goßner

Senior Escalation Engineer for SharePoint (WSS, SPS, MOSS, SP2010) and MCMS

SharePoint 2010 SP2 and Windows Server 2012 R2

SharePoint 2010 SP2 and Windows Server 2012 R2

  • Comments 19
  • Likes

Starting May 1st, 2014 SharePoint 2010 SP2 slipstream media on VLSC and MSDN can be used to install SharePoint 2010 on Windows Server 2012 R2.

Only SP2 slipstream installations are supported on Windows Server 2012 R2 - you cannot first install RTM or SP1 and then SP2.

Be aware that that to get a supported environment it is required to have February 2014 CU or later installed on top of the SP2 slipstream installations.

Also be aware that OS in place upgrade is NOT supported with SharePoint 2010. You need to perform a fresh installation of SharePoint 2010 SP2 slipstream on top of Windows Server 2012 R

References:

  • KB 2687453 - Description of SharePoint Server 2010 SP2
  • KB 2724471 - SharePoint 2010 support for Windows Server 2012 and Windows Server 2012 R2
Comments
  • Is build 2581604 is now replaced with build 4178583?
    What is the upgrade process from 2581604 to 4178583 hosted on Windows Server 2012 R2?
    Thanks!

  • Hi tmay,
    what are these numbers?
    They are not kb numbers nor SharePoint build numbers.
    please explain.

  • Stefan, these numbers are appended to the ISO builds I have downloaded from MSDN.
    1/15/2014: en_sharepoint_server_2010_with_service_pack_2_x64_dvd_2581604.iso
    5/2/2014: en_sharepoint_server_2010_with_service_pack_2_x64_dvd_4178583.iso

    I built a farm on Windows 2012 R2 in Jan 2014 with the 2581604.iso and wondering if I need to rebuild or just load the latest CU's.

    +Tony

  • Hi Tony,
    just update to the latest CU.
    Cheers,
    Stefan

  • Stefan, can you please clarify a few things here..

    First of all there is KB2724471 that you reference, which was last updated November 21, 2013 (shortly after Windows Server 2012 R2 was released) and which says: "SharePoint Server 2010 with SP2 has now been released, and this configuration is supported in Windows Server 2012 and Windows Server 2012 R2". You're apparently saying that this KB-article is incorrect because Windows Server 2012 R2 is NOT supported unless you install the February 2014 CU or later?

    Then there is KB2687453 to which this line was appended: "Deployments from the slipstream media at Microsoft Volume License Service Center (VLSC) and MSDN can now be performed on Windows Server 2012 R2 as of May 1, 2014", which is also what you mention in the first paragraph of your blog.

    Please address the fact that there are actually two versions of the "SP2 slipstream". The en_sharepoint_server_2010_with_service_pack_2_x64_dvd_2581604.iso that tmay245 mentioned was released on August 15, 2013 (before Windows Server 2012 R2 was released) and made available (with a different filename) on VLSC on December 16, 2013. Then there is the refreshed en_sharepoint_server_2010_with_service_pack_2_x64_dvd_4178583.iso (named SW_DVD5_SharePoint_Server_2010w_SP2.2_64Bit_English_MLF_X19-65035.ISO on VLSC) which was released on April 30 2014.

    Besides a bunch of renamed .wsp files, the refreshed SP2 slipstream has two updated files: prerequisiteinstaller.exe and svrsetup.dll. I think it is safe to assume these were updated specifically to fix Windows Server 2012 R2 installation issues, and that it is therefore best to install SharePoint 2010 SP2 on Windows Server 2012 R2 using the refreshed SP2 slipstream and not use the original one anymore?

  • Hi Gerard,
    I cannot say much to the first part - I know about these inconsistent messages but all I know is that the current message is that Feb CU has to be installed - I guess that some issues have been identified later but I don't have details.

    Regarding the ISO images: yes the pre-req installer now supports W2K12R2.
    So yes: please use the new images.

    Cheers,
    Stefan

  • Very good explanation Gerard

  • Hello Stefan,

    regarding your Statement "Also be aware that OS in place upgrade is NOT supported with SharePoint 2010. You need to perform a fresh installation of SharePoint 2010 SP2 slipstream on top of Windows Server 2012 R2"

    I want to ask you if the following is supported:

    1. I install a fresh Installation of SP 2010 (Server Standard) SP 2 Slipstream on Windows Server 2012 R2
    2. I take the Content Databases from another SharePoint Farm (SP 2010 RTM on Windows Server 2008 R2) and attach them to the new SP Farm (SP 2010 (Server Standard) SP 2 Slipstream on Windows Server 2012 R2)

    Is this scenario supported?

    Kind Regards!

  • Hi Iseesharp,
    DB attach is supported.
    Cheers,
    Stefan

  • Hello Stefan,
    I want to install SharePoint 2010 on Windows 2012 R2.
    My environment is not connected to the internet. I used to work with a PS script that downloads all the prerequisite files for Windows 2008 R2, but now I guess I need to download updated files.
    I was trying to look it up online, but couldn't find any.
    This TechNet article doesn't put any information on that either: http://technet.microsoft.com/en-us/library/cc288751(v=office.14).aspx
    Can you provide the updated links to the Windows 2012 R2 compatible prerequisite files?
    Thanks!

  • Hi Elad,
    you can run the prereq installer on a system that has internet access and then you will see the URL to each prereq file in the setup log.
    Cheers,
    Stefan

  • hi Stephan, we are planning an OS upgrade from server 2008R2 to 2012 R2, we are running sp 2010 in a 4 tier farm production. Do i need to create a new farm or can I evict servers from current farm one at a time, reload the os and SharePoint to the same version service packs and CUs then add them back to the farm, in other words would SharePoint function with mixed operating systems until all the servers are upgraded?

  • Hi Deon,
    Yes, SharePoint can be used with such mixed OS until all the servers are upgraded.
    Cheers,
    Stefan

  • Thank you Sir, keep up the good work, one quick question ''Be aware that that to get a supported environment it is required to have February 2014 CU or later installed on top of the SP2 slipstream installations'' is this supported state for Server 2008 R2 or just for the server 2012 slipstream. What is the minimum supported service pack and CU state that Microsoft supports?

  • That is just for server 2012 R2.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment
Raw Html Fix