SSCE 3.5 is not supported with SQL Server 2005 Management Studio. You need to use either the SQL Server Management Studio in SQL Server 2008 or Server Explorer in Orcas Beta 2 to query SQL Compact 3.5 databases.