Windows 7

Blog von Microsoft Deutschland

Windows 7 Beta: Erster Eindruck

Windows 7 Beta: Erster Eindruck

  • Comments 2
  • Likes

Gastbeitrag von Mathias Raacke, freiberuflicher Microsoft Certified Trainer, Berater bei der Umsetzung von .NET-Projekten, Architekt und Entwickler. Als Sprecher, "Instructor-led Lab Presenter" oder "Ask the Expert" ist er auf zahlreichen nationalen und internationalen Konferenzen wie z.B. TechEd, BASTA! oder ICE anzutreffen.

Windows 7 gab es zwar schon länger über verschiedene inoffizielle Kanäle, aber leider nur in der 32bit Version. Gestern hat Microsoft endlich die offizielle Beta veröffentlicht, und nach mehreren Stunden Download konnte ich mein Vista endlich auf Windows 7 upgraden.

Vor dem Upgrade musste ich zunächst die SP2 Beta von Vista und Windows PowerShell deinstallieren. Danach ließ sich Windows problemlos upgraden. Das Upgrade hat allerdings furchtbar lange gedauert – ca. 5 1/2 Stunden. Eine Neuinstallation hätte weniger als 30 Minuten benötigt (es waren schon in einer virtuellen Maschine weniger als 30 Minuten, und die ist ja langsamer). Vielleicht habe ich vor dem Upgrade vergessen, den Energiesparmodus abzuschalten – jedenfalls war er direkt nach dem Upgrade eingeschaltet. Das könnte die lange Dauer erklären, denn dann wäre mein Rechner ja nur auf halber Leistung gelaufen.

Ich verwende einen 2. Monitor, den ich über eine DisplayLink USB Grafikkarte angeschlossen habe. Ich hatte nicht damit gerechnet, dass diese unter 7 sofort funktionieren würde, denn bis vorgestern gab es auf der DisplayLink Homepage noch keinen Treiber für die 7 Beta. Pünktlich zur Beta hat DisplayLink aber einen neuen Treiber veröffentlicht. Einen kleinen Nachteil hat dieser allerdings schon gegenüber dem Vista Treiber: ich kann nur 2 Displays gleichzeitig nutzen, d.h. z.B. nur die beiden externen. Das Notebook-Display lässt sich nicht mehr als weiteres Display aktivieren, unter Vista hat das noch funktioniert. Ich gehe aber stark davon aus, dass dieses Problem in einer der nächsten Treiberversionen von DisplayLink behoben wird.

Wie erwartet funktioniert UltraMon nicht mehr. UltraMon ist ein Programm, das die Taskleiste auf mehrere Bildschirme erweitern kann, und dann auf jedem Bildschirm auch nur die Programme in der TaskLeiste anzeigt, die auf dem jeweiligen Bildschirm laufen. Da sich an der TaskLeiste unter Windows 7 sehr viel geändert hat, überrascht es mich nicht, dass UltraMon nicht mehr funktioniert.

Aero Glas wird bei mir nur noch ohne Transparenz angezeigt, die Rahmenfarbe wechselt dabei ab und zu zwischen schwarz und weiß. Wenn ich die Farbe in den Einstellungen ändere, kann ich zwar Farbe, Transparenz usw. einstellen, aber sobald ich das Einstellungsfenster schließe ist wieder alles schwarz, die Einstellungen werden nicht gespeichert.

Durch die vielen positiven Berichte über die Performance von Windows 7, unter anderem auch beim Booten, hatte ich hier mit größeren Änderungen gerechnet. Leider scheint Windows aber noch genauso schnell (bzw. langsam) zu booten wie vorher. Mit der Geschwindigkeit allgemein bin ich sehr zufrieden – die Geschwindigkeit war schon unter Vista sehr gut, und ist mindestens genauso schnell geblieben. Nur das Booten könnte eben noch etwas schneller gehen.

An der neuen TaskLeiste gefällt mir nicht, dass Fenster automatisch gruppiert werden und nur ein Icon pro Programm angezeigt wird. Das lässt sich zum Glück aber in den Eigenschaften der TaskLeiste abschalten (siehe Screenshot). Ansonsten ist die neue TaskLeiste sehr ungewohnt, aber ich denke wenn ich mich darauf eingestellt habe wird sie mir besser gefallen als die alte Variante von XP/Vista.

image

Bis auf die hier erwähnten kleineren Macken läuft Windows 7 bisher sehr gut, schnell und stabil. Die Qualität ist deutlich höher als die jeder Beta von Windows Vista. Noch zu Vista-Zeiten hätte Microsoft ein Windows auf diesem Niveau vielleicht schon als fertige Version verkauft. Da Microsoft noch mehrere Monate an Windows 7 weiter arbeiten wird gehe ich davon aus, dass Windows 7 sehr ausgereift und stabil sein wird, wenn es fertig ist.

Comments
  • Nachdem ich nun die ISO von W7 heruntergeladen habe, wollte ich natürlich sofort etwas "erleben". Also Laptop raus, los geht´s.

    Hardware (für die Technikinteressierten):

    Samsung NP-R50CV03/SEG

       Motherboard:

         CPU Typ                                                   Mobile Intel Pentium M 740, 1733 MHz (13 x 133)

         Motherboard Name                                  Samsung R50/R51

         Motherboard Chipsatz                              Mobile Intel Alviso i915PM

         Arbeitsspeicher                                         2048 MB  (DDR2-667 DDR2 SDRAM)

         DIMM1: Kingston 9905295-015.A00LF          1 GB DDR2-667 DDR2 SDRAM  (5-5-5-15 @ 333 MHz)  (4-4-4-12 @ 266 MHz)  (3-3-3-9 @ 200 MHz)

         DIMM3: Kingston 9905295-015.A00LF          1 GB DDR2-667 DDR2 SDRAM  (5-5-5-15 @ 333 MHz)  (4-4-4-12 @ 266 MHz)  (3-3-3-9 @ 200 MHz)

         BIOS Typ

                                                                         Phoenix (11/02/05)

       Anzeige:

         Grafikkarte                                                ATI MOBILITY RADEON X300  (64 MB)

         Grafikkarte                                                ATI MOBILITY RADEON X300  (64 MB)

         3D-Beschleuniger                                       ATI Mobility Radeon X300 (M22)

       Multimedia:

         Soundkarte                                               Analog Devices AD1981B(L) @ Intel 82801FBM ICH6-M - AC'97 Audio Controller [B-1]

       Datenträger:

         IDE Controller                                            Intel(R) 82801FB/FBM Ultra ATA-Speichercontroller - 266F

         IDE Controller                                           Ricoh Memory Stick Host Controller

         IDE Controller                                           Ricoh xD-Picture Card Controller

         Festplatte                                                 SAMSUNG HM160HC ATA Device  (160 GB, 5400 RPM, Ultra-ATA/100)

         Festplatte                                                 SD Memory Card

         Optisches Laufwerk                                   TEAC DV-W28EA ATA Device  

         Speicherkapazität                                     139.0 GB (106.5 GB frei)

       Eingabegeräte:

         Tastatur                                                   Standardtastatur (PS/2)

         Maus                                                       PS/2-kompatible Maus

       Netzwerk:

         Netzwerkkarte                                     Broadcom 440x 10/100-integrierter Controller

         Netzwerkkarte                                     Intel(R) PRO/Wireless 2200BG Network Connection

       Peripheriegeräte:

         FireWire Controller                               Ricoh RL5C552 IEEE1394 Controller (PHY: Ricoh RL5C552)

         USB1 Controller                                   Intel 82801FBM ICH6-M - USB Universal Host Controller [B-1]

         USB1 Controller                                   Intel 82801FBM ICH6-M - USB Universal Host Controller [B-1]

         USB1 Controller                                   Intel 82801FBM ICH6-M - USB Universal Host Controller [B-1]

         USB1 Controller                                   Intel 82801FBM ICH6-M - USB Universal Host Controller [B-1]

         USB2 Controller                                   Intel 82801FBM ICH6-M - Enhanced USB2 Controller [B-1]

    Zur Installation:

    Aus Angst, es könnte schiefgehen, habe ich zuerst ein Update von Vista Business SP1 durchgeführt - 3 1/2 Stunden!

    Die Hälfte meiner Software hat sich dann laufend mit Abstürzen und Fehlermeldungen bedankt. Ergo: Wie gehabt, Neuinstallation ist am Besten.

    Vorher sollte man natürlich prüfen, in wie weit man auf manche Hard- /Software verzichten kann. Ich hatte da z.B. erst Probleme mit dem Windows Mobile Device Center.

    Doch dazu später.

    Partition freigeräumt

    DVD rein, gestartet, gestaunt. Die ganze Installation bis zum ersten Erscheinen von Betta (der Kampffisch, lat. Bezeichnung) dauerte 27 min.

    Windows Update gestartet, (das hat länger gedauert, als die Installation - wohne auf dem Dorf - völlig DSLfrei, also mit ISDN. War der 2. Kaffee)

    Neustart - Jede Hardware wurde erkannt und eingerichtet, auch der Sound! (noch mal gestaunt)

    Software installiert: Adobe CS3, O2007, Avira

    PDA (mit WM6.1) angesteckt, automatische Erkennung ging an, 1/2 Std. Treiberdownload (Kaffee Nr. 3) - GEHT!

    Frau kommt gucken, was der Liebste da schon wieder tackert: "Das sieht aber schick aus, was ist das? Geht das bei meinem auch?"

    Süffisant gelächelt und gesagt: "Ja, noch dieses Jahr, kostet ca. 150€", sie sagt: "Dann spar schon mal!"

    Nach weiteren 2 Stunden Entdeckungsfahrt habe ich dann den ersten Fuffi in die Sparbüchse geschoben.  

    Alles in Allem ist es sehr bemerkenswert, dass W7 in der Betaversion auf meinem alten Faltbaren besser läuft als Vista, trotz Debugcode und grafischen Effekten.

    Was würde ich mir noch wünschen:

    Abgleich der Favoriten mit anderen Rechnern, ähnlich wie bei Foxmark for IE (läuft übrigens auch auf W7), vielleicht über die LIVE - Plattform? Wer kennt das nicht, auf Arbeit eine wichtige Seite in die Favoriten geschickt, zu Hause - "Wo war das noch mal?"

    Differenzierte Installation "Standard" - "Benutzerdefiniert" - Haken raus oder rein. Für CD-Brennen, Schreiben und Grafik benutze ich eher "erwachsene" Programme wie Nero (läuft auch ab Version 8), Adobe und Office. Da würde ich z.B. Paint, Moviemaker, Wordpad und Brennapplet mal eben außen vor lassen.

    Die Möglichkeit einer "Familienlizenz" (eine Version kaufen mit 3 Lizenzen und "Mengenrabatt")

    Fazit: W7 ist mal wieder eine Software, wo ich mich auf den Tag freue, wenn sie erscheint. Sollte ich in meinen PDA ein DVD-Laufwerk rein bekommen, installiere ich da auch W7!  

    Gruß Mirko

    den Blog lesen könnt Ihr unter

    http://cid-90a392d012c69092.spaces.live.com/blog/cns!90A392D012C69092!147.entry?&_c02_vws=1

  • Nun hat mein altes Samsung R50 den Geist aufgegeben - der IDE-Controller ist hin. Kommt natürlich nicht von W7, sondern vom Alter. Ist wohl wie bei den Menschen, je älter, desto vergesslicher? Ich habe auch schon Alzheimer-light.

    Nun gut. Habe mir ein neues Laptop geholt, ein ASUS F5Sr. Geht ganz gut, habe aber leider erst zu Hause gemerkt, dass ein SIS-Chipsatz drin ist. Nun gut, erstaunlicher Weise ließ sich auch darauf problemlos W7 installieren. In der Vergangenheit war das ja eben bei SIS nicht immer so mit Betaversionen.

    ASUS-typisches Problem: ATK0100 ACPI Utility ließ sich nach "erzwungener" Installation lösen. (nach neuem Treiber suchen - auf dem Computer... - \Windows\SoftwareDistribution\Download\)

    Eine Sache verwundert mich noch: ein Dienst namens msisadrv hat im Gerätemanager einen gar cryptischen Namen (kann es jetzt nicht aufschreiben, weiß den ANSI-CODE für diese Zeichen nicht). Man findet das, wenn man bei "Ansicht" "ausgeblendete Geräte anzeigen" aktiviert.

    Alle Geräte wurden erkannt, Das Catalyst-Center für Vista funktioniert auch auf W7 (ohne Catalyst ist die Ausgabeeinstellung auf den zweiten Monitor mehr als dürftig)

    Weiterhin auf W7 installiert und getestet (funktioniert auch):

    -Adobe Fotoshop CS3

    -Adobe Acrobat 9

    -Adobe Premiere CS3

    -Office 2007 logischerweise

    -Nero 9 (durch die vielen Neuinstallationen verweigert da die Patentaktivierung mittlerweile den Dienst, eigenartiges Lizenzmodell, mit Verfallsdatum?)

    -Microsoft Expression Web (noch die Einser), Da allerdings kann man keine Grafiken einfügen, weil Verzeichnisse im Auswahldialog sich nicht öffnen lassen. Mag sein, dass es in der Zweier geht, mein "Budget" ist aber erschöpft, die muss noch warten.

    -Avira Antivir Premium

    Mein lieber Schwan, jetzt wird mir mal bewusst, wie viel Geld ich da schon für Software ausgegeben habe ...

    So, jetzt wird der Alltagsbetrieb zeigen, wie "belastbar" W7 schon ist.

    Gruß Mirko!

    den gesamten Blog könnt Ihr hier lesen:

    http://cid-90a392d012c69092.spaces.live.com/blog/cns!90A392D012C69092!163.entry?&_c02_vws=1

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment