Exchange Connector 3.0 RTM Bug Fix Available Now

Exchange Connector 3.0 RTM Bug Fix Available Now

  • Comments 24
  • Likes

ImportantUpdated 10/28/2013: You can now download the fixed version directly without having to contact Microsoft product support and opening a case. You can download the updated connector here: http://www.microsoft.com/en-us/download/details.aspx?id=38791

=====

As many of you discovered and pointed out, there is a bug in the Exchange Connector 3.0 RTM that is related to extending the work item classes data model with custom properties.  For example, this could happen when you import the Send Email MP which extends the incident class.  When this happens, the impacted work item will not be updated and you will see an event like this in the Operations Manager event log:

Exchange Connector: Unable to process mail item. Subject="xxxxxxxxxxxxx  ID: [IR###]", Error Message=The key value of an object cannot be changed.

A fix is available for this issue now by calling Microsoft support and creating a case.  We encourage you to only use this approach if it is absolutely necessary.  A new build of the Exchange Connector 3.0 with this fix will be available in 1-2 months and will be available for download without creating a support case.  That will be much faster/easier if you can wait for that.

Thank you for your patience and helping us identify this issue!

J.C. Hornbeck | Solution Asset PM | Microsoft GBS Management and Security Division

Get the latest System Center news on Facebook and Twitter:

clip_image001 clip_image002

System Center All Up: http://blogs.technet.com/b/systemcenter/
System Center – Configuration Manager Support Team blog: http://blogs.technet.com/configurationmgr/
System Center – Data Protection Manager Team blog: http://blogs.technet.com/dpm/
System Center – Orchestrator Support Team blog: http://blogs.technet.com/b/orchestrator/
System Center – Operations Manager Team blog: http://blogs.technet.com/momteam/
System Center – Service Manager Team blog: http://blogs.technet.com/b/servicemanager
System Center – Virtual Machine Manager Team blog: http://blogs.technet.com/scvmm

Windows Intune: http://blogs.technet.com/b/windowsintune/
WSUS Support Team blog: http://blogs.technet.com/sus/
The AD RMS blog: http://blogs.technet.com/b/rmssupp/

App-V Team blog: http://blogs.technet.com/appv/
MED-V Team blog: http://blogs.technet.com/medv/
Server App-V Team blog: http://blogs.technet.com/b/serverappv

The Forefront Endpoint Protection blog : http://blogs.technet.com/b/clientsecurity/
The Forefront Identity Manager blog : http://blogs.msdn.com/b/ms-identity-support/
The Forefront TMG blog: http://blogs.technet.com/b/isablog/
The Forefront UAG blog: http://blogs.technet.com/b/edgeaccessblog/

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment
  • thank you! waiting for the downloadable release

  • Travis,

    Holding the project for 1-2 months is not an ideal solution for me at this time. Is it okay to deploy the connector if we didn't extend the incident class?

    Thanks!

  • @Sadda -

    Yes.  Keep in mind that this error can occur whenever you extend any work item class, not just incident.

  • Travis,

    Thanks for the heads up! Looking forward for the quick bug fix release.

  • This issue was solved after getting the Hotfix from MS Support!

    It just brings the "Microsoft.SystemCenter.ExchangeConnector.dll" in a newer Version.

    Thx for the fast bugfix!

    Best, Alex

  • MS Support is unvilling to provide the FIX, without a KB number. Does anyone know the KB number for this fix? Thanks :-)

  • nemozem sa pripojit na dorucenu postu

  • Alex,

    That's a good news.

  • I really have to make a case?  Why not just post a link to the .dll if thats the fix.  Wouldn't that save us all a lot of time?

  • We also made a call and received the Hotfix and everything is working again.

  • The update does appear to address the "Unable to process mail item" issue, but appears to have broken logging of the Exchange Connector to the Operations Manager log...  Is anyone else seeing this...

    FYI, the updated DLL is dated 6/23/2013, version 7.5.2017.13...

  • Good morning Travis - I was wondering 2 things. The exchange connector...old and new... Anyone who can complete a manual activity even they are not the activity implemeneter. Is that going to be changed anytime in the future? We just had an incident where someone received and e-mail and completed the activity when it wasn't theirs.

    2nd question is attachments to review and manual activities.....so far I've been testing things and I can send all the attachments I want to both and I don't see anything telling me there are any attachments to either. The deployment guide tells me I can attach files to either....is this true or just an error in the documentation?

    Thanks

  • "A new build of the Exchange Connector 3.0 with this fix will be available in 1-2 months and will be available for download without creating a support case.  That will be much faster/easier if you can wait for that."

    It's been 2 months. Any idea where I can find the fix without opening a support case?

  • Where can I find the hotfix now? Will it be resolved in R2 version?

  • Hi All,

    I've been trying to get hold of MS Support for a number of hours now - Would it be possible for anyone who has the hotfix to contact me via BUNCEatINTERNODEdotONdotNET ?

    It would be greatly appreciated!