Blogs

The rest of the Server Core hardware story

  • Comments 8
  • Likes

I think I got a little carried away talking about the SC command line tool last week and how to use it to help manage drivers. So carried away in fact, that I forgot to explain how to install a new driver.

 

For hardware that has an in the box driver in Longhorn Server, you just need to install the hardware, startup the server, and log on to the box. Plug and Play will detect the hardware change, rescan, and automatically install the driver. There is no UI or need for administrator interaction. In the case of a new network adapter, running IPconfig will show the new adapter and its IP address (if you are using DHCP). You can also use SC.exe to see that it was installed, but I told myself no rambling about SC.exe this week, so you’ll have to look at last weeks post for the details on using it.

 

For hardware that does not have a driver included in Longhorn Server, such as a new piece of hardware that comes out after release, as long as you have a PnP driver for it, it can be installed from the command line. To do this, you need to either copy the driver files to a temporary folder on the Server Core box or make them available on a network share. In Server Core beta 2, you then run the Drvload.exe command to install them, pointing the tool at the driver inf file:

Drvload <path>\<driver>.inf

This will install the driver in the repository and kick off a PnP rescan, which will detect the hardware, find the new driver, and install it for you.

 

Hopefully this fills in the gap in the hardware story that I left last week.

 

Andrew

Comments
  • Thanks for the syntax.  That'll help my implementation - trying to think "core" is interesting at best, but I think the end product will be worth it.

  • One important thing to mention is that the drivers have to be signed! If they are not you'll get an error...

  • I received the following error:
    "Drvload: Unable to load <correct drive path to driver.inf> (Error 0xe000023f)."

    Any thoughts?  These VMware drivers might not be signed.

  • Yes, I forgot to mention that, in beta 2 the drviers do need to be signed. We are looking into a solution for that for beta 3.

    I haven't seen that error before, when you install the drivers in a regular install do you get prompted that the drivers aren't signed?

  • Yes.  In regular Longhorn, it does warn about being an unsigned driver, so I will have to wait until beta 3 before loading customized drivers.  I am sure the platform (VMware VM) is probably not on the HCL.

  • I am not sure what drivers cnschindler was trying to install. But I am in the process of setting up LH Server Core Beta 2(build 5384) on Vmware Server 1.0 (Build 28343). Installed core and as I guessed there were no drivers. No experimental support for LH from Vmware yet in the free server product, but managed to get the NIC drivers from http://www.amd.com/us-en/assets/content_type/utilities/V4.51.zip as per a VMware forum post and all is well so far.

    HTH

    M@

  • Just wanted to say the vista experimental support works fine in LH. Please ignore comment of "no experimental support".

  • Sorry the VMware driver issue seemed to be bowulf's issue no cnschinder. Sorry about that too ;-0

    M@

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment