블로그 플랫폼 개편으로 지난 수요일 소식을 이제 전해드립니다.

보안 권고 2028859를 통해 공지한 바와 같이, 윈도우의 캐너니컬 디스플레이 드라이버(Canonical Display Driver)인 cdd.dll에 원격 코드 실행 취약점이 있는 것으로 보고되었습니다. 이번 취약점은 윈도우 7 64비트 (x64), 윈도우 서버 2008 R2의 64비트와 아이태이니엄 시스템에만 존재합니다.

cdd.dll은 윈도우의 GDI (그래픽 디바이스 인터페이스)와 다이렉트X 컴포넌트의 특정 부분을 담당하는데 이번 취약점을 악용할 경우 응답이 없어지거나 시스템이 재시작될 수 있습니다. 메모리 주소 임의화(ASLR)와 커널 메모리 임의화 기능으로 인해 임의의 코드 실행이 무척 어려울 것으로 보이지만 이론상 가능하기는 합니다. 그리고 시스템에 에어로 테마가 적용된 경우에만 공격이 가능한데 윈도우 서버 2008 R2는 에어로 지원 그래픽 드라이버가 들어있지 않고 기본 상태로 꺼져 있습니다.

보안 패치가 나와야 할 취약점이지만 아직 패치 일정은 정해지지 않았습니다.

보안 권고를 읽고 예방 조치를 취하시기 바랍니다.