OpenSolaris (build 63) on Virtual PC 2007 - part deux

OpenSolaris (build 63) on Virtual PC 2007 - part deux

  • Comments 1
  • Likes

I have to imagine that when the OpenSolaris release team decided on a launch strategy, that they sat around a table and discussed:

How can we go out of our way to make the download of the install ISO the must painful, frustrating, experience possible?

As there are some sharp folks working at Sun, they utterly succeeded at their goal.

You must:

  • Register at their page (Download)
  • Click accept on the licence agreement
  • Check 3 boxes (for all 3 parts of the download that is inexplicably separated)

  • That launches the Java Download Manager (with advertisements), which downloaded the 3 parts of the ISO at a whopping 10-12 KB/s.  All other downloads come down at 400-500KB/s, so I don't know why the Sun download was so glacially slow.  Part "b" of the ISO failed to download 5 or 6 times over the course of a week before it eventually downloaded successfully.

  • Next, we have the command-line-driven join of the ISO parts.

Finally... a week after I intended to start the review, I can start the installation in Virtual PC.

No GUI install for Solaris... text based install it is!  Java, apparently, is a critical component of the install.  It is one of the first things that load:

At some point, it tried to load a GUI, but the video resolution went wonky, and eventually I was dropped back in to the text-based install:

After an incredibly long timeout (5+ minutes) while OpenSolaris attempted (unsuccessfully) to reach a DHCP Server, we reach the HD formatting dialogue.  YOO MUST HAS SKILLZ to format your own drive.  I'd better go with the Auto Layout option...

Apparently "Auto Layout" didn't have the "advanced system administration skills" needed to format the drive:

Apparently I had breezed by the following screen, where I had to manually partition the drive, before Auto Layout could format it:

There we go... now Auto Layout can give me a friendly File System layout.  <sarcasm> This is the kind of screen I'd like my Grandma to end up at while installing an Operating System </sarcasm>. 

For the next 1 1/2 to 2 hours, the installer chugged along.  Only after COMPLETELY installing all files did I receive an error message stating that Solaris could not install with only 512MB of RAM (as much as I had allocated to the virtual machine).  I am flabbergasted as to why Solaris would wait until this point in the game to do a prerequisite Sanity Check. Fortunately, as this was a Virtual Image, I was able to shut down the virtual machine, allocate the required 768 MB of RAM, and start the image back up.

Leading me to... the messed up video display.  To be honest, I could probably reboot into single user mode, modify the X Server config, and maybe get video display to work.  The network card does not work either, and I have spent the better part of two whole days working on this.  I am going to give up as I have better things to do...  At present, OpenSolaris does NOT get The Sean Blog Seal of Approval :)

Comments
  • Download the NexentaOS vmware image instead (see www.gnusolaris.org). It works perfectly.  Or, download the NexentaOS DVD image and install in Virtual PC.  It should work great!

    NexentaOS is built on opensolaris.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment