New Fix: Attempting to login to the SCVMM self-service portal fails with "Could not load file or assembly"

New Fix: Attempting to login to the SCVMM self-service portal fails with "Could not load file or assembly"

  • Comments 3
  • Likes

KBAttempting to login to the System Center Virtual Machine Manager 2008 (SCVMM) self-service portal may fail with the following error message in the browser:

Could not load file or assembly ‘TraceWrapper,
Version=1 .0.523.0, Culture=neutral,
PubhcKeyToken=31bf3856ad364e35’ or one of its
dependencies. An attempt was made to load a
program with an incorrect format.
Login again
Contact administrator

This can occur if the application pool for SCVMM self-service portal is configured with Allow 32-bit Applications set to “True” in the Advanced Settings.

By default on a 64-bit machine, the Application pool in IIS 7 has the Allow 32-bit Applications setting set to false, however in certain environments the application pool may have Allow 32-bit Applications configured as True. In these cases we will receive error message as stated above. To resolve this issue change the Allow 32-bit Applications setting to False from True. To do that perform the following steps:

    • Open the IIS admin console.
    • Right-click the Application pool corresponding to SCVMM and select Advanced settings.
    • Under the Advanced settings, select the Allow 32-bit Applications setting and change it to False.

    For the latest version of this article please see the Knowledge Base article below:

    KB2397656 - Attempting to login to the System Center Virtual Machine Manager 2008 self-service portal fails with "Could not load file or assembly"

    J.C. Hornbeck | System Center Knowledge Engineer

    The App-V Team blog: http://blogs.technet.com/appv/
    The WSUS Support Team blog: http://blogs.technet.com/sus/
    The SCMDM Support Team blog: http://blogs.technet.com/mdm/
    The ConfigMgr Support Team blog: http://blogs.technet.com/configurationmgr/
    The OpsMgr Support Team blog: http://blogs.technet.com/operationsmgr/
    The SCVMM Team blog: http://blogs.technet.com/scvmm/
    The MED-V Team blog: http://blogs.technet.com/medv/
    The DPM Team blog: http://blogs.technet.com/dpm/
    The OOB Support Team blog: http://blogs.technet.com/oob/
    The Opalis Team blog: http://blogs.technet.com/opalis

    clip_image001 clip_image002

    Your comment has been posted.   Close
    Thank you, your comment requires moderation so it may take a while to appear.   Close
    Leave a Comment
    • fixed to run at IIS, but how to build/debug it in VS. i got the same error while build a project with TraceWrapper.dll included. then i have to exclude it while building and add it to bin while running in IIS.

    • appended one thing:

      it's a web site, and i can find a place to change the platform setting of project to x64.

    • We did all this but of no use Error exist can anybody suggest other work around Hurry up plzzzzzzzzzzzzz