The following are Prerequisites for App-V 5.0 Client on Windows 7:

  • Microsoft Windows .NET Framework 4.5. This eliminates the Microsoft Windows .NET Framework 4 requirement.
  • Windows PowerShell 3.0
  • Update for Windows KB2533623

I first enabled the Quick Fix Engineering Inventory Class, then I created a Configuration Manager 2012 Application and used the following PowerShell query to Detect if Update for Windows KB2533623 is installed.

Get-WmiObject Win32_QuickFixEngineering | where {$_.HotFixID -eq "KB2533623"}

This worked great until KB2567680 was released and superseded KB2533623 so I had to update my Detection Script to the following:

Get-WmiObject Win32_QuickFixEngineering | where {$_.HotFixID -eq "KB2533623" -or $_.HotFixID -eq "KB2567680"}

I then set the Update as a Dependency for the App-V 5.0 Client Deployment.