Error 0x80004005 When Accessing /EXCHANGE or /PUBLIC Virtual Directory

Error 0x80004005 When Accessing /EXCHANGE or /PUBLIC Virtual Directory

  • Comments 4
  • Likes

[Today's post comes to us courtesy of Justin Crosby, David Santamaria, and Damian Leibaschoff]

Users may receive the following error when access /EXCHANGE or /PUBLIC on an SBS 2008 server.  Users can still access OWA using the /OWA path.  Note: SBS 2008 users should always use /OWA or RWW to access OWA.  This issue is a very rare issue, but if encountered can take a very long time to troubleshoot.

Error Summary
HTTP Error 500.0 - Internal Server Error

The page cannot be displayed because an internal server error has occurred.

Detailed Error Information:
Module IsapiModule
Notification ExecuteRequestHandler
Handler AboMapperCustom-2575299
Error Code 0x80004005
Requested URL https://localhost:443/exchange
Physical Path \\.\BackOfficeStorage\domain.local\MBX
Logon Method Negotiate

image

You may also see the following event in the application event log:

Log Name:      Application
Source:        DAVEX
Date:          2/26/2009 3:47:04 PM
Event ID:      101
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      server.domain.local
Description:
DAVEX to be shutdown. Version: 8.1.240.5

This issue can occur if the HKLM\SYSTEM\CurrentControlSet\Services\InetInfo\Parameters registry key is missing.  To resolve this issue recreate the key and restart IIS.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment
Comments
  • PingBack from http://www.ditii.com/2009/03/02/sbs-2008-troubleshooting-error-0x8004005-when-accessing-exchange-or-public-virtual-directory/

  • Hi All,

    Sorry, cant seem to find where to create a new post

    however i am experiencing a similar problem when my users got to https://servername/exchange and clicks logon gets HTTP/1.1 503 Service Unavailable, i have tried several tips over a few months but cant seem to get OWA to function again.. I think this error occured right after a nasty poweroutage.. please help

    email me at doctorgsrg@gmail.com

  • Wizdemon,

    You should utilize the newsgroups, or open a support case for help with your specific issue.

    Regards,

  • I know that the certificate issued in exchange 2007 is not good enough and we need to create a new certifcate with external domain and the services needed like IIS, IMAP, POP, .....

    Thus this problem applies also to SBS2008, do we need to replace the self created certifcate by the server with new one ????

    asslan@gmail.com