2nd UPDATE: Installing Hotfix 948110 on SBS 2003 Servers

2nd UPDATE: Installing Hotfix 948110 on SBS 2003 Servers

  • Comments 33
  • Likes

We have received a few reports of hotfix 948110 causing issues with SharePoint (Companyweb) on SBS 2003.  At this time please hold off on installing this patch on your SBS 2003 server.  Installing this hotfix may prevent the SharePoint WMSDE instance from starting.  We are currently investigating the issue and will update this blog post as soon as possible.

Update 1:

If you have already installed this hotfix AND the MSSQL$SHAREPOINT service is not starting you can perform the following steps to fix this service.

  1. Rename C:\Program Files\Microsoft SQL Server\MSSQL$SHAREPOINT\Binn to Binn.old
  2. Restore C:\Program Files\Microsoft SQL Server\MSSQL$SHAREPOINT\Binn from a backup taken previous to installing hotfix 948110.  If you do not have a backup try using volume shadow copy.
  3. Start the MSSQL$SHAREPOINT service
  4. Test CompanyWeb

This should fix CompanyWeb.  If you go to Windows Update you will once again be offered update 948110, do not install this update for the time being.

Update 2:

We have determined that this issue only occurs on Small Business Server 2003 Server in which CompanyWeb was upgraded to SQL 2000 from WMSDE and was neverupdated to SQL SP4.  If your CompanyWeb site is still using WMSDE (the default) you can go ahead and apply this update.  If your CompanyWeb has been migrated to SQL 2005 this issue also does not apply to you and you can apply this update.  If you have been affected by this issue or you have updated to SQL 2000 please review this: http://blogs.technet.com/sbs/archive/2008/07/11/cannot-access-company-web-after-installing-948110.aspx.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment
Comments
  • just got an update from internal blog that we should not uninstall the patch..wondering if we can tweak in registry rather than uninstalling.

  • PingBack from http://blog.sbs-rocks.com/2008/07/09/hold-off-on-installing-hotfix-948110-on-sbs-2003-servers/

  • Just installed security updates today, July 9, 2008 and lost internet connectivity on a desk and laptop. Used restore to regain connectivity succussfully. Whats going on with these very recent updates?  Also, with automatic updating, the updates reappear on prior restore points as well.  I won't install them again!

  • ElCattivo, the issue you address is about the DNS patch.  Do you have Zone Alarm installed?  If so this is the reason why.

    You need to reinstall them and to determine the root cause.

  • The Official SBS Blog : UPDATED: Hold Off on Installing Hotfix 948110 on SBS 2003 Servers: http://blogs

  • So those of us with a 2003 server with Sharepoint 3.0 with no backup (Just built it a month ago and testing it out before adding it to our backups) are SOL?

  • Arnel:  We have not had any reports of this issue effecting SharePoint 3.0 on SBS 2003 when SharePoint is installed using the side-by-side whitepaper.  Please call support to report your issue.

  • Anil:  I am not sure what blog you are refering to but there is no registry tweak that will fix this issue.

  • Well your description is identical to my situation.

    Windows update finished at 3:05 am last night and my server log states.

    Database MICROSOFT##SSEE is running.

    All the services are running, I even restarted them.

    But get The description for Event ID ( 27745 ) in Source ( Windows SharePoint Services 3 ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: #50071: Unable to connect to the database STS_Config on GENSRVSP006\MICROSOFT##SSEE.  Check the database connection information and make sure that the database server is running..

    I'll try calling support.

  • I had the problem also.  It turned out that there are a few updates with number 948110 (e.g. an update on SQL Server SP4 ; an update on the Server 2003 OS ; ...).

    The strange thing was that some of them were installed and one of them was not.

    So, I pushed that one to install also and after that I was able to keep MSSQL$Sharepoint running, which made everything to work again.

  • It has been reported that hotfix 948110 is causing problems with sharepoint - problems that will prevent the service from running (so your companyweb site will be down!) From the SBS blog: If you have already installed this hotfix AND the MSSQL$SHARE

  • So is there a way to uninstall it or fix it yet?  My sharepoint is down.

  • The Official SBS Blog is reporting that Hotfix 948110 is causing issues on SBS2003 servers. Hold off

  • I don't have those Binn files, can you guys post them?

  • This hotfix seems to also be effecting IPSEC as well.  We were able to use http://support.microsoft.com/kb/912023/en-us, followed by a reboot, as a work around to get back up and running.