Ram Ojha's Blog

Unfied Communications Diary...

Outlook Integration Error - Microsoft office Communicator 2007!

Outlook Integration Error - Microsoft office Communicator 2007!

  • Comments 6
  • Likes

During my job as unified communications engineer, one of the frequent problems I encounter is "Outlook Integration Error" warning alert, appearing in Microsoft Office Communicator 2007.

Assuming that you have outlook 2007 and Microsoft office Communicator 2007 installed on the client, I follow the following steps to ensure that the issue gets resolved.

1. I ensure that MOC 2007 and Outlook 2007 are properly patched.

2. Check if the SIP Address and Primary email address are same. If they aren't same, follow the following kb.

http://support.microsoft.com/kb/951644

 3. Ensure that the Exchange 2007 web services are configured and behaving properly. The Autodiscover service should be configured on https in order to ensure that the Microsoft Office Communicator gets free\busy information properly.

=========================================================================================================

Anish K Pandey  (Exchange Support Engineer - anishp@microsoft.com) talks further about how to resolve the "Outlook Integration Error" if it is caused by the Exchange Web services.

Before we begin, we should understand how Autodiscover in Exchange 2007 works. Here is the whitepaper link for Autodiscover: http://technet.microsoft.com/en-us/library/bb332063.aspx and to understand Availability Service here is the link: http://technet.microsoft.com/en-us/library/bb232134.aspx.

 

Note: Autodiscover should be working over HTTPS for the Office Communicator to get the Free/Busy information via Availability service.

 

Scenario 1:

 

In the case where an Internal MS Certificate OR Self Signed Certificate is configured on Client Access Server. There are few things which we should keep in mind.

As the Internal MS Certificate is not trusted publicly, we have to install the ROOT CA on every client where we are using Outlook 2007 SP1 & Office Communicator. Outlook clients can get the AVAILABILITY service on HTTP, I mean if Autodiscover fails on HTTPS then it would fall back to HTTP and find the SCP (Service Connection Point), however Office Communicator will not fall back on HTTP as it only works on HTTPS to get the Availability service which in-turn updates the free/busy information. (as mentioned earlier, in absence of free\busy information the MOC 2007 will report "Outlook Integration Error"). Self Signed Certificate is not supported for Communicator EWS access. If EWS is configured with self-signed certificate, MOC will keep reporting "Outlook integration error" or "Exchange integration error".

Secondly we should have the Autodiscover & EWS virtual directories in IIS on Windows Integrated Authentication method.

We should also make sure that URLs for ClientAccessServer, EWS are set properly. Please refer kb article: http://support.microsoft.com/kb/940726 (I have fixed many cases with this article).

 

Scenario 2:

 

In the case where a 3rd Party Certificate is being used (like VeriSign, Go Daddy etc) then we just have to follow the above step 2 & 3 as the 3rd Party certificates (no need to install the ROOT CA on each and every Windows based client machines, as Windows CE does have these certs by default) are publicly trusted.

=========================================================================================================

Outlook DLLs used by Microsoft Office Communicator

 

Comments
  • PingBack from http://amdtalk.com/1969/ram-ojhas-blog-outlook-integration-error-microsoft-office/

  • We have just upgraded from Exchange 2003 to 2007.  Prior to the upgrade Communicator worked just fine on and off the network.

    After the upgrade we are seeing issues!  Autodiscover is working fine for out Outlook 2007 clients on and off the network.

    Communicator works fine on the network.  However, when we go off the network we see a problem.  When Communicator starts it authenticates fine to the OCS edge server and the buddy list loads fine.  After a few seconds though, you are prompted for a password to download Outlook information, if you enter your password everything appears to be ok.

    Using WireShark, we see OC making various requests for autodiscover.  We are using the SRV record configuration.  We see it request then fail and move on to another DNS request.  Ultimately is tries the SRV record and gets a valid response and then throws up the password prompt!  Why?  Any ideas?

  • I found the answer here...

    http://blogs.msdn.com/scottos/archive/2008/10/16/why-is-communicator-prompting-me-for-credentials.aspx

  • I was going mad about this error. Thanks for sharing this info. I follow this blog pretty closely. Any idea why voice mail tab is grayed out in outlook? Thanks in advance!

  • You can try the following link...

    http://www.ocspedia.com/Misc/Voice_tab_disabled_Outlook.htm

  • I am facing problem with MS outlook in receinving and sending my email. Please help me  Thanks

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment