With the release of Windows 7, and client workstations trending to a 64-bit operating system, inquiries about ProClarity installation prerequisites have steadily increased.  ProClarity Professional includes 'SQLServer2005_ASOLEDB9.msi' which is the 32-bit version of the Analysis Services 9.0 OLE DB Provider.  The installer attempts to install this as a prerequisite before installing ProClarity Professional, and on a 64-bit operating system you might see this error message:

ProClarity Install Prerequisites

The solution to this is to manually install the x64 version of the Microsoft SQL Server 2005 Analysis Services 9.0 OLE DB Provider.  To manually install the provider what you'll want to do is go to the latest Feature Pack for Microsoft SQL Server 2005 (currently December 2008) download site and download the install file, install the provider, and then install ProClarity.

Microsoft Download