Deployment-Minor PDT update 2.5.2508 now available

Deployment-Minor PDT update 2.5.2508 now available

  • Comments 28
  • Likes

PDT 2.5.2508 is now available on the TechNet Gallery here.  This release adds download locations for the two Windows Server MPs required for Operations Manager integration with Virtual Machine Manager, and corrects the filesize validation for the Configuration Manager Prerequisites download.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment
  • Hello Rob,

    thx for the new PDT, the SC R2 Comnonents won't download. I removed the comments in the download area of the workflow.xml, but the the downloads links of the R2 components don't work. I download SC R2 with Akamai downloader and test the PDT again.

    best regards

    Markus  

  • Markus - please see previous post, which explains that the R2 components cannot currently be downloaded by Downloader.ps1.

  • 1) Downloaded and expanded SCCM 2012 R2 to c:\Temp\SystemCenter2012R2\ConfigurationManager

    2) created c:\Temp\SystemCenter2012R2\ConfigurationManager.DL

    3) ran C:\Temp\SystemCenter2012R2\ConfigurationManager\SMSSETUP\BIN\X64\setupdl.exe

    4) Pointed to c:\Temp\SystemCenter2012R2\ConfigurationManager.DL

    5) re-ran Installer.ps1 -ValidateOnly

  • Setting up the SCCM Prerequisites - that will work.  Alternatively, just do step 1 then re-run Downloader.ps1 and it will do the rest for you.

  • After deployment of the virtual machines, I run the Installer.ps1 script and validation fails with "Current user access.....Failed" Any ideas why this could be happening? There are no log files. Only the App Controller files.

    Charles

  • Hello Rob,

            When running the Installer.ps1 script, all of prerequisites pass. It is when I get to the "Validating Server and Access" phase of the script, I get the following errors:

    Validating servers and access...

       Server: SC2K12R2CM01.msft2k12.local

         Current user access... Passed

         MSFT2K12\Installer access... Passed

       Server: SC2K12R2DB01.msft2k12.local

         Current user access... Failed

         MSFT2K12\Installer access... Failed

       Server: SC2K12R2DB02.msft2k12.local

         Current user access... Failed

         MSFT2K12\Installer access... Failed

       Server: SC2K12R2DB03.msft2k12.local

         Current user access... Passed

         MSFT2K12\Installer access... Passed

       Server: SC2K12R2DB04.msft2k12.local

         Current user access... Failed

         MSFT2K12\Installer access... Failed

       Server: SC2K12R2DB05.msft2k12.local

         Current user access... Failed

         MSFT2K12\Installer access... Failed

       Server: SC2K12R2DPM01.msft2k12.local

         Current user access... Failed

         MSFT2K12\Installer access... Failed

       Server: SC2K12R2OM01.msft2k12.local

         Current user access... Passed

         MSFT2K12\Installer access... Passed

       Server: SC2K12R2OR01.msft2k12.local

         Current user access... Failed

         MSFT2K12\Installer access... Failed

       Server: SC2K12R2RD01.msft2k12.local

         Current user access... Failed

         MSFT2K12\Installer access... Failed

       Server: SC2K12R2SM01.msft2k12.local

         Current user access... Failed

         MSFT2K12\Installer access... Failed

       Server: SC2K12R2SM02.msft2k12.local

         Current user access... Failed

         MSFT2K12\Installer access... Failed

       Server: SC2K12R2SM03.msft2k12.local

         Current user access... Failed

         MSFT2K12\Installer access... Failed

       Server: SC2K12R2VMM01.msft2k12.local

         Current user access... Failed

         MSFT2K12\Installer access... Failed

    Validation failed

    There are no log files created in the Users\Administrator.domain\AppData\Local\Installer\Temp directory only in the Log directory Controller.0 and Controller.1 files

    Any assistance would be greatly appreciated.

    Thanks In Advance,

    Charles A. Windom Sr.

  • Charles - validation does not produce log files since everything is output on screen.  Those validation errors mean that either those servers don't exist, the users don't have admin access, or possibly a firewall is blocking access.

  • Hello Rob,

           The installer account is in the domain admins group. The firewall is on, should I disable it while deploying? Also I have run the script without the -ValidateOnly switch and still does not product any logs. Also the servers were deployed with the VMCreator.ps1 script

    Thanks,

    Charles

  • Hello Rob,

           I also ran the Installer.ps1 script without the -ValidateOnly switch and I get no logs as well. I have deployed the virtual machines mentioned in errors with the VMCreator.ps1 script and the are all fully functional and joined to the domain.  Should I disable the firewall while deploying? Just trying to get System Center 2012R2 installed for evaluation.

    Thanks In Advance,

    Charles

  • Charles - what does the following give you?  That is what is doing the validation.

    Get-WMIObject -Class Win32_OperatingSystem -Namespace root/cimv2 -ComputerName SC2K12R2DB01.msft2k12.local -ErrorAction SilentlyContinue

    If this fails, it is possible that some other policy in your environment is blocking.

  • Hello Rob,

               When I run your command, nothing gets returned but when I run the command without the

    -ErroAction SilentlyContinue, I get the following error message:

    Get-WmiObject : The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)

    At line:1 char:1

    + Get-WmiObject Win32_OperatingSystem -Namespace root/cimv2 -ComputerName SC2K12R2 ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

       + CategoryInfo          : InvalidOperation: (:) [Get-WmiObject], COMException

       + FullyQualifiedErrorId : GetWMICOMException,Microsoft.PowerShell.Commands.GetWmiObjectCommand

    I have done searches for the error and have followed their suggestions to no avail. The RPC Services are running. To eliminate the firewall, is there anything the firewall needs to be enabled for? All servers are registered in DNS and nslookup can resolve them. Remote management is enabled on all of the servers. I've even put the installer service account into the domain and enterprise admins groups just to see if it were a permissions issue. As far as the domain, this is a newly created domain, so no policies other than the default domain policies are active. What am I missing?

    Thanks In Advance,

    Charles A. Windom Sr.

  • Charles - that appears to be the problem, communications between your systems are not functioning correctly.  Is WMI allowed through the firewall?

  • Hello Rob,

            After further analysis, I found out that DNS entries for some of the servers were incorrect. I have gotten to installing the products but now I am failing to install some of the products. Here is a summary of the last run:

    Runbook Designer: SC2K12R2RD01.msft2k12.local: Failed dependency System Center 2012 R2 Configuration Manager Site Server: 00:14:58

    Console: SC2K12R2RD01.msft2k12.local: Failed dependency System Center 2012 R2 Configuration Manager Site Server: 00:14:55

    Console: SC2K12R2RD01.msft2k12.local: Failed dependency System Center 2012 R2 Configuration Manager Site Server: 00:14:55

    System Center 2012 R2 Configuration Manager

    Database Server: SC2K12R2CM01.msft2k12.local: Failed to install System Center 2012 R2 Configuration Manager Site Server: 00:23:26

    Provider Server: SC2K12R2CM01.msft2k12.local: Failed to install System Center 2012 R2 Configuration Manager Site Server: 00:23:26

    Site Server: SC2K12R2CM01.msft2k12.local: Failed to install System Center 2012 R2 Configuration Manager Site Server: 00:23:26

    Console: SC2K12R2RD01.msft2k12.local: Failed dependency System Center 2012 R2 Configuration Manager Site Server: 00:14:55

    System Center 2012 R2 Service Manager

    Web Content Server: SC2K12R2SM01.msft2k12.local: Failed dependency System Center 2012 R2 Configuration Manager Site Server: 00:23:22

    SharePoint Web Parts Server: SC2K12R2SM03.msft2k12.local: End SC2K12R2SM03.msft2k12.local: 00:20:42

    Console: SC2K12R2RD01.msft2k12.local: Failed dependency System Center 2012 R2 Configuration Manager Site Server: 00:14:56

    System Center 2012 R2 Data Protection Manager

    Database Server: SC2K12R2DPM01.msft2k12.local: End SC2K12R2DPM01.msft2k12.local: 00:06:43

    Reporting Server: SC2K12R2DPM01.msft2k12.local: End SC2K12R2DPM01.msft2k12.local: 00:06:43

    Server: SC2K12R2DPM01.msft2k12.local: End SC2K12R2DPM01.msft2k12.local: 00:06:43

    Console: SC2K12R2RD01.msft2k12.local: Failed dependency System Center 2012 R2 Configuration Manager Site Server: 00:14:56

    SQL Server 2012

    Reporting Server: SC2K12R2CM01.msft2k12.local: Failed to install System Center 2012 R2 Configuration Manager Site Server: 00:23:27

    Management Tools: SC2K12R2RD01.msft2k12.local: Failed dependency System Center 2012 R2 Configuration Manager Site Server: 00:14:56

    I will look through the log files (and there alot of them ;-) ) to see if I can find the issues.

    Thanks for Your Assistance,

    Charles A. Windom Sr.

  • Hello Rob,

    wenn I start the Installer.ps1 -validateOnly, I get the error "ConfigMgr.Manifest.cab incorrect size" back

    I have allredy download from C:\Temp\SystemCenter2012R2\ConfigurationManager\SMSSETUP\BIN\X64\setupdl.exe.

  • Heinz - please make sure you are using Workflow.xml version 2508.  Also, you can run Downloader.ps1 again to update your downloaded files.  If that files, can you check the filesize of the failing file please.