Patrick Heyde

Coming from SharePoint Support & Living in SQL BI & Moving to Windows Azure

SharePoint 2010 JuneCU 2011 available (+ side effect info & solution)

SharePoint 2010 JuneCU 2011 available (+ side effect info & solution)

  • Comments 4
  • Likes

Hello @all,

in my last post I wrote SP1 release, download and installation info. On the same day, product group publish JuneCU 2011, which run on build level: 14.0.6106.5000.

KB 2536601 – SharePoint Foundation 2010 – Download 
KB 2536599 – SharePoint Server 2010 – Download

After installing JuneCU please run: SharePoint Configuration Wizard or “psconfig –cmd upgrade –inplace b2b -wait”.

On my environment I found a side effect which requires a little additional action to solve:

Symptom: User Profil import stop working with stopped-extension-dll-exception” errors in miiserver.exe

Error Details:

"System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.PlatformNotSupportedException: Microsoft SharePoint is not supported with version 4.0.30319.235 of the Microsoft .Net Runtime.
   at Microsoft.SharePoint.Administration.SPConfigurationDatabase.get_Farm()
   at Microsoft.SharePoint.Administration.SPFarm.FindLocal(SPFarm& farm, Boolean& isJoined)
   at Microsoft.SharePoint.WebControls.SPControl.SPWebEnsureSPControl(HttpContext context)
   at Microsoft.SharePoint.SPContext.get_Current()
   at Microsoft.Office.Server.UserProfiles.ProfileManagerInstance.GetApplicationProxy()
   at Microsoft.Office.Server.UserProfiles.ProfileImportExportService.FinalizeProfileImportExportProcess(Int64 importExportId)
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle._InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at Microsoft.Office.Server.WebServiceDirectProxy.WebMethodInfo.Invoke(Object webServiceInstance, Object[] args)
   at Microsoft.Office.Server.WebServiceDirectProxy.Invoke(String methodName, Object[] args)
   at Microsoft.Office.Server.UserProfiles.ManagementAgent.ProfileImportExportDirect.FinalizeProfileImportExportProcess(Int64 importExportId)
   at Microsoft.Office.Server.UserProfiles.ManagementAgent.ProfileImportExportExtension.Microsoft.MetadirectoryServices.IMAExtensibleCallExport.EndExport()
Forefront Identity Manager 4.0.2450.34"


I’ve highlighted the important stuff. SharePoint 2010 run on .net 3.5 and not on .net 4.0.

As solution we have two options:

1. Workaround:  uninstall .net 4.0 from Windows Server

or even better

2. Workaround: configure process execution

There’s an easier workaround to force FIM use the .NET Framework v2.0 version:
1. Open the c:\Program Files\Microsoft Office Servers\14.0\Synchronization Service\Bin\miiserver.exe.config file for editing.
2. Locate the below section:

<startup useLegacyV2RuntimeActivationPolicy="true">
  <supportedRuntime version="v4.0.30319"></supportedRuntime>
  <supportedRuntime version="v2.0.50727"></supportedRuntime>
</startup>

3. Delete or comment out the reference for the .NET v4 version. Like this:

<startup useLegacyV2RuntimeActivationPolicy="true">
 <!-- <supportedRuntime version="v4.0.30319"></supportedRuntime> -–>
 <supportedRuntime version="v2.0.50727"></supportedRuntime>
</startup> 

or

<startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v2.0.50727"></supportedRuntime> 
</startup>

4. Restart the two FIM services in the services console.
5. Run the sync again.

 

[Updated 21.07.2011]  2nd issue detected: my colleague Stefan Goßner wrote a blog post:
"After you install the earlier build of this hotfix package, the following services may fail at either runtime or the provision process (psconfig upgrade operation) if you run these services by using a user account other than the farm administrator account: Session State Service, Secure Store Service, Business Data Connectivity (BDC) Service" http://blogs.technet.com/b/stefan_gossner/archive/2011/07/12/june-2011-cu-for-sharepoint-2010-has-been-re-released.aspx

I hope it helps.

regards

Patrick

Comments
  • Do we still need to Follow this after installing the patched June 2010 CU for SPS2010 that was re-released?

  • Hi Akhil, no it should be fix with the re-release.

    regards

    patrick

  • I am receiving the same error.  I checked the config file and I didn't have 4.0.  I have 2.0.  Do you have any other suggestions?

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment