The System Center Operations Manager Support Team Blog

This is the OpsMgr 2007 blog for the Microsoft support team. If you were looking for the SCOM 2007 or MOM 2005 blog then you are in the right place.

OpsMgr 2007: The DBCreatewizard utility fails with a BadImageformatException when run on a 64-bit OS

OpsMgr 2007: The DBCreatewizard utility fails with a BadImageformatException when run on a 64-bit OS

  • Comments 1
  • Likes

I'm going through a couple older issues and posting the resolutions just in case one of you happen to see the same thing.  The first regards running DBCreateWizard on a 64-bit OS:

========

Issue: The DBCreatewizard utility fails with BadImageformatException when run on a 64-bit OS:

System.BadImageFormatException: Could not load file or assembly 'Microsoft.Mom.UI.Wrappers, Version=6.0.4900.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'Microsoft.Mom.UI.Wrappers, Version=6.0.4900.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
   at Microsoft.EnterpriseManagement.Setup.DBCreateWizard.ManagementGroupPage.ButtonBrowse_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

This is also triggered if you specify a non-default value for the security group that will be inserted into the MOM Admins role (by clicking the “browse” button to select some user/group for MOM Admin).

Cause: When the DBCreateWizard and associated DLL's are copied from the SupportTools folder of the Service Pack 1 (SP1) media, the DLL's copied are not those for a 64-bit Windows OS. The associated DLLs include:

  • Microsoft.EnterpriseManagement.UI.ConsoleFramework.dll
  • Microsoft.Mom.UI.Common.dll
  • Microsoft.Mom.UI.Wrappers.dll

Resolution: Clicking 'Continue' appears to succeed in creating the database without further issue but doesn't allow a reset of the security group to a non-default value.  To fully resolve the issue, copy the associated DLL files from the install folder on an amd64 machine on which the Operations Console is installed.

========

Hope this helps!

J.C. Hornbeck | Manageability Knowledge Engineer

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment