The latest version of Opalis may have been a big release because of the new support for Windows Server 2008 and the new System Center Integration Packs, but it's still an upgrade – it requires installing 6.2.2 first. This, along with the fact that Opalis is comprised of several components and not everything was updated leads to some confusion among those getting going with 6.3.

First of all, be sure you follow the installation instructions for 6.2.2, SP1 and 6.3. If you are installing on a 64-bit OS, go through all of the steps of the installation before you actually start running anything. Remember that 6.2.2 is not supported on Windows Server 2008 64-bit operating systems, so trying to use Opalis on that OS before having 6.3 installed might result in odd behavior,.

Once you get everything installed, go take a look in Add/Remove Programs ("Programs and Features" in 2008) and see if everything matches what I show here:

image

Note that the Quick Integration Kit (QIK) was updated in this release, so you'll want to uninstall 3.1.0 and install 3.1.1.

If you happen to have been part of the 6.3 beta, you really should completely uninstall and reinstall Opalis (especially if you worked with the ConfigMgr IP) because of major DB changes during the beta. If the DB is ok, you should click on View Installed Updates at the top of the Control Panel page and scroll down to see the Opalis Updates.You might see something like this:

image

If you see this, DO NOT simply uninstall the patch and then apply the 6.3 patch. Doing so may likely corrupt your installation (as it did mine, requiring me to go back to a previous snapshot). Instead, simply uninstall the Management Service, then go back to the 6.2.2 setup and go through "Install the Management Server:". Once that completes, it will automatically show the rest as complete. Then you go back into the 6.3 release files and re-apply the patch.

When you're done, you should see the following updates in the list:

image

What about the Action Server? It still shows 6.2.2, right? Well, that's OK because the Action Server was not updated in 6.3.

What about "Help / About" in the Client? We actually didn't update the client itself – only the help files. This is why the Client still shows 6.2.2.5229 as the version number.

Hopefully this will help you figure out whether all the components in your installation are at the correct version.