When upgrading your Exchange 2010 CAS to SP2 you may encounter the following error:

The "IIS WMI Compatibility" component is required.  Install the component via the Web Server Manager.

 

The IIS6 WMI Compatibility is a new prerequisites for upgrading to Exchange 2010 SP2

To upgrade from the command line without erros run:

setup.com /m:upgrade /InstallWindowsComponents

To upgrade from the GUI without erros

Before you run the Exchange SP2 setup program on your CAS Servers do the following:

 

  • On the Start menu, navigate to All Programs > Accessories > Windows PowerShell. Open an elevated Windows PowerShell console, and run the following command:
    Import-Module ServerManager
  • Use the Add-WindowsFeature cmdlet to install the necessary operating system component:
    Add-WindowsFeature Web-WMI