SharePoint 2010 vs IIS MIME maps for MP4s

SharePoint 2010 vs IIS MIME maps for MP4s

  • Comments 4
  • Likes

Another internal email we’re sharing with the world! This one was written by Karl Reigel, who’s a US-based Premier Field Engineer. Thanks Karl!

Had an interesting issue with a customer that I thought I’d share in case anyone else runs across the same issue.

Background:  SharePoint 2010 environment with BLOB Cache enabled and Browser File Handling set to “permissive”.  The customer wanted to have MP4s open up in the browser, or just open up when clicked on in SharePoint. They set up the MIME type at the site level in IIS:

Screen Capture 1:  The screen capture below shows the MIME type being set at the Web Site level in IIS

clip_image002

Adding the MIME type at the site level results in the MP4 being displayed as text (which is not nearly as friendly as watching a video.)

Screen Capture 2:  The screen capture below shows the video displayed as text when setting the MIME type at the site level in IIS.

clip_image004

Symptoms: 

1. The video displays as text (see Screen Capture 2)

2. The ULS log will contain an entry like:

No configured MIME type for requested file 'D:\BlobCache\14\1912228005\3xrWwTmni0KJRcav1t8UJQ\SITES\TEAMSITE\VIDEOS\ SAMPLEVIDEO-_TfWgAETB0qdKBvgv7XlAQ.MP4’

Cause:  The cause is that SharePoint looks to the Server Level for the MIME Map. PublishingHttpModule handles the Authorize request, and looks up the mime map during this process.

The mime map is built from the old metabase APIs and reads the information from the machine level, not the site level.

Solution:  Set the MIME type at the Server Level.  The user will also probably need to delete their browser cache on the client depending on how they have their browser configured.


Screen Capture 3:
  The screen capture below shows the MIME type being configured at the server level
clip_image006

That helps with those MIMEs which leaves us with what to do with these:

clip_image008

Just thought I’d pass that little nugget along in case anyone else runs into this.


Posted by Tristan Kington, MSPFE Editor, while rediscovering the joys of Virtual Pool.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment
  • Hi Just what I'm after. Although I have a question : Is the "server level" iis? Or are you referring to someplace else? Thanks.

  • It's the server object in the IIS manager interface, see Screen Capture 3.

  • It worked! Thank you so much!

  • this solved my issue, thank you!