Now that Configuration Manager 2012 RC2 is available, people will certainly start updating their labs – and finding out that the SQL version check in the ConfigMgr installer is looking for some very specific SQL maintenance levels.  (I’ve pulled out plenty of my own hair doing this recently.)  The release notes cover the supported versions:

Supported versions of SQL Server 2008 for RC2:

  • SQL Server 2008 SP2 Standard and Enterprise CU7
  • SQL Server 2008 R2 SP1 and CU4
  • SQL Server Express 2008 R2 and CU4

If you are running SQL 2008 SP2, install CU7 from http://support.microsoft.com/kb/2617148. If you are running SQL Server 2008 R2 SP1, use CU4 from http://support.microsoft.com/kb/2633146.  If you aren’t yet on the needed service pack levels, upgrade now, then install the cumulative updates :-)