Off Campus

Michael Greene

Blogs

UAG Setup system.exception

  • Comments 1
  • Likes

Was just building a UAG test server in our lab and came across an error, which was easily resolved and worth posting for others.

From the splash screen I clicked install only to receive a “system.exception” error.  Even if I ran the .msi file directly, I would get a failure.

A search returned one brief mention of a fix.  I had a Group Policy applying to the machine that was disabling the Windows Firewall.  As soon as I moved the machine account to a test OU where the policy would not apply and rebooted to refresh, the issue went away.  Setup now runs without issue.

update 4/17...

This is also mentioned in the troubleshooting section - http://technet.microsoft.com/en-us/library/ff607359.aspx

Further testing proved this may also occur if the Remote Settings for RDP are set to allow.

Comments
  • Thanks Michael,

    Recently I made a similar observation regarding to UAG setup and System.Exception.

    1. If you log on locally, setup starts.

    2. If you log on directly using Remote Desktop, setup starts.

    3. If you log on using Remote Desktop through Remote Desktop Gateway, setup fails (exactly as you described — i.e. System.Exception and nothing more).

    3a This happens even if you connect from the same computer you used in step 2 (and setup worked).

    3b And even if you connect directly (not using RDG) from the RDG computer, setup works.

    So this is not connection origin issue, but an RDG issue.

    Hope this helps someone.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment