Matt Goedtel on Operations Management

Posts in this blog are provided "AS IS" with no warranties, and confers no rights as specified in the Terms of Use

Some MP Reports Are Not Deployed to the Reporting Services Server

Some MP Reports Are Not Deployed to the Reporting Services Server

  • Comments 4
  • Likes

Shortly after implementing Operations Manager 2007 and upgrading to RC Service Pack 1 in my customer's lab environment, I noticed the following errors in the Operations Manager Event Log on the RMS stating:

Failed to deploy reporting component to the SQL Server Reporting Services server. The operation will be retried. Exception 'UnauthorizedAccessMonitoringException': The user Domain\mgmtDR does not have sufficient permission to perform the operation. One or more workflows were affected by this. Workflow name: Microsoft.SystemCenter.DataWarehouse.Deployment.Report Instance name: SERVERNAME.Domain.com Instance ID: {BFA9FF77-3A74-02CE-B7ED-1E0835652EBE} Management group: MgmtGroup-01

The Event was generated from the SDK Service and the Event ID was 26319.  When I was attempting to run some of the Active Directory and Windows Server Base OS Reports, the Root Container for the reports were listed, but not the individual reports themselves.  Of course I did verify that we granted the Data Reader account the required rights, and obviously it did since the reports from other Management Packs were available in the Reports view.  After doing some troubleshooting and not making any relevant progress, I raised a flag with the Product Group and they suggested adding the Data Reader account to the MOMAdmins Group (which basically gives it "GOD" rights in Operations Manager).  After adding it to the Global Group and not the Operations Manager Administrators User Role directly, I recycled all the services on the RMS.  Shortly thereafter the reports were successfully deployed to the Reporting Services server.  I then removed the Data Reader account from the Global Group and recycled the services again on the RMS to restore the security settings back to the recommended configuration. 

Some other colleagues and customers have experienced this with other Management Pack reports, such as the newly released DNS MP.    Right now if you are working with RC Service Pack 1 and you encounter this issue, utilize this workaround until otherwise informed.

The Product Group is researching this to identify what the cause of the insufficient security permissions for the Data Reader account.  Especially since we want to make sure that Service Pack 1 is solid when released early next year. 

Comments
  • PingBack from http://geeklectures.info/2007/12/19/some-mp-reports-are-not-deployed-to-the-reporting-services-server/

  • I rarely comment on blogs but yours I had to stop and say Great Blog!!

  • Did the permissions issues every get nailed down?  I'm seeing the same thing on the OCS R2 MP as well and would like to know what I can do (apart from giving the ID temp GOD access) to fix this.

  • I get the exact same error when I import the Management Pack for OCS 2007 R2 Ver.6.0.6907.21. What is interesting is that even after i gave domain admin permissions to the DWR account, the error is still there. This is on SCOM 2007 R2 CU2. There are no errors if i remove this MP.

    Is there anything else I should try to resolve this ?

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment