지원되지 않는 게스트 OS - Hyper-V에서 공식적으로 지원하는 운영 체제는?

지원되지 않는 게스트 OS - Hyper-V에서 공식적으로 지원하는 운영 체제는?

  • Comments 1
  • Likes

(사진출처 : http://unisia.egloos.com/4503690)

Windows Server 2008의 Hyper-V내 Windows 운영 체제를 설치하신 후, 위와 같은 오류가 발생하는 경우가 있다는 이야기를 일전부터 많이 들어왔었습니다. 마침 오늘 회사분중 한분의 블로그에 댓글로 달린 내용도 동일한 내용인 관계로 아예 포스팅을 해서 기록에 남깁니다. :)

한글 버전에서는..

"지원되지 않는 게스트 OS

오류가 발생했습니다. 지정한 프로그램에는 Windows의 새 버전이 필요합니다."

영문 버전에서는..

"Unsupported Guest OS

An error has occurred: The specified program requires a newer version of Windows."

조금은 당황스러운 에러 메시지이지요. 새버전의 Windows가 과연 뭘까? 제 경우엔 Windows 2000 Server를 테스트하려고 오래된 시디를 꺼내서 설치했더니, 통합 서비스(Integration Components) 설치 디스크를 넣었을 때 이런 메시지가 나왔죠.

Windows Server 2008내 Hyper-V는 모든 버전의 Windows를 지원하는 것이 아니라, 각 Windows의 서비스 팩 수준에 따라 지원여부가 달라집니다. 제품을 지원하지 위해서는 수반되는 테스트가 필요한데, 해당 테스트를 마친 서비스 팩을 의미하는 것이죠.

관련된 공식 문서는 Microsoft.com내 기술 지원 사이트내 Guest operating systems that are supported on a Hyper-V virtual machine host에서 살펴보실 수 있습니다.

서버 버전

image

Linux

image 

클라이언트 버전

image

Comments
  • I have this problem installing Windows Server 2003 Ent with SP1, now I will install the SP2 and then I'll try to install the integration tools.

    :)

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment