Winter?  I'm sleeping through it! To Hibernate, or NOT to Hibernate…

Question 2:
“I like using Hibernate.  But after I installed [an antivirus program that shall not be pointed to here], hibernate stopped working.  I don’t even have an option in the menu anymore.”

There are a couple things that may have messed with hibernate.  Apparently there was an issue with the Disk Cleanup feature (and I’m not sure if this is pre-SP1 only, or even a “feature” of disk cleanup) that disabled the hibernation file, which caused hibernate to be shut off.  Of course I have no way of knowing whether your antivirus program somehow messed with your hibernation file (hiberfil.sys), but anything is possible.

It may also be that you have “hybrid sleep” enabled on your machine. 

For those of you not aware of what that is: hybrid sleep is like sleep, but more safe; it also will save your memory to the hard disk for safe keeping.  This is particularly useful on desktop computers.  These don’t typically have batteries, so if the power goes out, the old XP-style of sleep (“standby”) wouldn’t be able to recover from something really nasty like an unexpected power outage.  Laptops, with their batteries, are of course more resilient in that way… so they don’t really need hybrid sleep in most cases.  But you do want that memory to be saved if the battery is getting low.  So by default, it will save memory to disk when the battery is getting low.

“Hybrid Sleep also saves my memory to disk?  That sounds like hibernate!”

Right.  But with the added benefit of quicker sleep and re-awakening.  In fact, it’s so much like hibernate that the hibernate option also goes away if you have hybrid sleep enabled.

So – how do you re-enable hibernate if you really want it?  You still want to have the option to go completely “zero-power-consumption” right away?

First, make sure that hybrid sleep is turned off in the advanced settings of your power options.

image_thumb2

And if that alone doesn’t do it, then follow the simple steps of using the “powercfg –h on” command from an elevated command-prompt to re-enable the hibernation file.

--

So.. what are you doing?  Sleep?  Hibernate?  Migrate south for the winter?