KB Article on a workaround to be able to apply SP4 here: http://support.microsoft.com/kb/2591380

Read about it at:  http://blogs.technet.com/b/momteam/archive/2011/08/10/scom-2007-r2-and-sp1-now-supports-sql-server-2005-sp4.aspx