The Windows Servicing Guy

Tips and tricks from a Windows support engineer on issues related to servicing

You receive exit code 0x800f081f when attempting to install SP1 for Win7/R2

You receive exit code 0x800f081f when attempting to install SP1 for Win7/R2

  • Comments 17
  • Likes

I've seen this a couple of times already, enough that I thought we should have some quick content on it.  When you attempt to install the standalone package for Service Pack 1 for Windows 7 you might get the following error:

0x800f081f  <--This maps to CBS_E_SOURCE_MISSING

You'll be prompted to run the CheckSUR utility and running that utility will not resolve the issue. 

This may be due to a pre-release version of the RSAT tools being installed on the system.  To alleviate this failure, do the following:

1.  Uninstall the pre-release RSAT tools

2.  Reboot the system

3.  Install the release version of the RSAT tools (http://www.microsoft.com/downloads/en/details.aspx?FamilyID=7d2f6ad7-656b-4313-a005-4e344e43997d&displaylang=en)

4.  Reinstall SP1.

Remember, if you want to utilize the RSAT tools with SP1 installations you must install them prior to upgrade until the repackaged RSAT tools are released in April.

If you have a Windows 2008 R2 Server installation that is getting the 0x800f081f error code then you are not hitting the RSAT tools issue.  You have a source file missing somewhere that is causing the issue.  I would recommend running the latest version of CheckSUR against the installation first to see if you have a missing or corrupted source file of some sort first.  Otherwise, we'd need to look over your logs to see what else is going on.  You can either open a post on the newsgroups or an issue with Microsoft support if you need assistance.

--Joseph

Comments
  • What are the pre-release RSAT tools called in the uninstall program list?

  • They should still be labeled the Remote Server Admin Tools

  • This does not work for Windows 7 Home Premium Edition. Pls review this solution.

  • This does not resolve my issue on a clean Server 2008 R2 install. Never had RSAT installed (don't think it will install). SP1 worked fine on an identical server...

    0x800f081f  still. Any other ideas?

  • I'm with Chris.  I never had the RSAT tools installed either and get the same message.  I went though all of the troubleshooting info I could glean short of a re-install.

  • Both of you will need to open issues on the forums and submit logs for review then.  It's easier for me to track.

  • I'm joining the Chris + Jim crowd.  Attempted an SP1 install on two relatively new Server 2008 R2 boxes.  Succeeded on one, got the error on the other.  Aren't the RSAT tools just for the remote client (hence the "R")?  The server OS has all that stuff built in so it doesn't need something installed, so that really can't be the problem, right?  

  • Correct, that wouldnt be the problem on a server release, only client.  Please start threads on the forums and cross-post your link here so we can review the logs on the machines.

  • Same issue - but here are some details.  No RSAT tools, however enabled remote server management.

  • Same issue, error 0x800f081f on try to install W7 Sp1 but no RSAT tools found on computer, sfc /scannow give no error.

  • Same issue, error 0x800f081f on try to install W7 Sp1 but no RSAT tools found on computer, sfc /scannow give no error.

  • Mario;  You'll need to open an issue with Microsoft on the forums or through support to have someone look over your logs.

  • The RSAT update should have a number of 958830 in the installed updates list - btw.

  • This seemed to work a treat for me: idoneitmyself.wordpress.com/.../troubleshooting-0x800f081f-error-on-windows-2008-r2-sp1-installation

  • aps's link is what finally solved the win 7 sp1 install problem for me.  I had tried all the info out there.  Uninstalled language packs. Installed Readiness Tool.  Nothing worked except: idoneitmyself.wordpress.com/.../troubleshooting-0x800f081f-error-on-windows-2008-r2-sp1-installation