The Windows Servicing Guy

Tips and tricks from a Windows support engineer on issues related to servicing

New years answer's cont'd

New years answer's cont'd

  • Comments 8
  • Likes

Second question that was asked was the following:

"Another one: Why is the /passive switch not supported for updates. With update.exe, there was a "/passive" switch that was IMMENSELY USEFUL when installing batch updates via a script as it was UNATTENDED but displayed the progress. WUSA only has the /quiet switch but does SILENT unattended installs. Please also support the /PASSIVE switch for future updates perhaps beginning with Windows 7 SP1. Right now I am forced to use a command prompt/cscript to install MSU updates to I can see its process has exited and the next one has begun installing."

I will leave this one short and sweet: This is something we are looking at for future releases.

Any other questions, ask away.  Aside from that I am going to work on posting some servicing mechanics in a blog entry in the near future.

--Joseph

Comments
  • I've got a question: if you use Dism to modify install.wim on the Windows 7 setup DVD (that is, a copy of the DVD!) the setup process won't work properly from that copy.  Specifically, some of the directory junction points get set to the path you mounted install.wim at instead of pointing to the appropriate folders on the new installation.

    Any idea why this happens?  Is there a supported way of installing updates directly into the setup image, like the /integrate flag used to do in XP?

  • Harry--

    Good question.

    What you would have to do is mount the install.wim to a folder, DISM in the fixes that you would want to install into it and then commit those changes and apply that .WIM with the IMAGEX tool.  You cannot make the modifications to the install.wim that is on media because that media cannot be rewritten to.

    Let me know if that doesnt make sense and I can go into it a little more.

  • Obviously the copy of the DVD I was modifying was on the HDD.  Making the changes to install.wim wasn't the problem; the problem was that the resulting operating system is corrupted.

  • How are you applying the .WIM file to the drive after you inject the changes?  You should be able to use IMAGEX without an issue.

    You also might want to look into MDT, its a free download and it takes care of a lot of this for you.

  • I'm running setup.exe.  I'll try using IMAGEX instead.

  • Nope, same problem using IMAGEX.  This should be easy to reproduce, and you can email me if you want to look into it - but it's not a big deal, at the end of the day.  The offline servicing pass will apply the updates quite handily.  Applying them on each target machine is less efficient than applying them to the image, of course, but it's not like there's a shortage of CPU cycles available. :-)

  • Harry

    What fixes are you integrating?  I'd actually like to see if I can repro this and see what the problem might be.  If you want to send me the steps, please do and I will look at this for you.

  • For the information of any other readers, we eventually tracked this down to a specific scenario, when there is a short filename in the MountDir argument.

    For more details refer to my blog post on the subject by clicking on my name above.