John Howard - Senior Program Manager in the Hyper-V team at Microsoft

Senior Program Manager, Hyper-V team, Windows Core Operating System Division.

Blogs

TechNet and Languages in Internet Explorer

  • Comments 2
  • Likes

I'm sure this isn't going to teach a lot of people anything new, but given I just noticed it myself, I think it's worth mentioning just in case. Due to my recent change of laptop, and the fact that my new laptop doesn't run Windows Server 2003 (actually it does, just not very well - the power settings are a nightmare), I'm back to a default install of XP still at the defaults for many settings. One such setting shows itself up in Internet Explorer. There's been a few sites over the past few days I've visited and noticed that I was getting US English settings (dates for example) rather than UK English, even though I set the language and keyboard input settings to UK English at XP install time. Fine - I could just wait a month and it wouldn't make a lot of difference. However, I double checked the Internet Explorer settings and found that even with the selected install options, for some reason the language was still set to "en-us" (US English). You can see this in action on numerous sites, for example http://support.microsoft.com which shows up as Microsoft US Support. More obviously an example is the newly designed TechNet site at http://www.microsoft.com/technet which, if you're set for UK English will redirect to http://technet.microsoft.com/en-gb/default.aspx. <shameless plug>Well worth a look.</shameless plug>

To check or change your language settings in IE6, select Tools/Options. On the general tab, click Languages near the bottom and add/remove the appropriate languages.

Comments
  • Although my language settings are set to en-gn it kindly informs me that all menus etc are in English(American). Also technet stays technet.com
    cheers

  • Hi Jay - hopefully that's a typo on your part any meant en-gb rather than en-gn. Assuming that is the case and there are no other higher-precedent langauges set in your browser, can you drop me a mail using the contact option at the top. I'll need some screenshots, browser version and os version and I'll find someone to forward the problem on to for resolution. I've tried to replicate this from three machines and can't so far.
    Thanks,
    John.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment