securitybulletin3

Earlier in the week we released an out-of-band security update to address a vulnerability in the Windows Shell which could allow a remote code execution.  More details are below and if you haven’t already applied this update make sure you do as soon as you can.

New Security Bulletin Overview

Bulletin ID Bulletin Title

Maximum Severity Rating

Vulnerability Impact Restart Requirement Affected Software
MS10-046 Vulnerability in Windows Shell Could Allow Remote Code Execution (2286198)

Critical

Remote Code Execution Requires Restart Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2

Details

This security update resolves a publicly disclosed vulnerability in Windows Shell. The vulnerability could allow remote code execution if the icon of a specially crafted shortcut is displayed. An attacker who successfully exploited this vulnerability could gain the same user rights as the local user. Users whose accounts are configured to have fewer user rights on the system could be less impacted than users who operate with administrative user rights.

This security update is rated Critical for all supported editions of Microsoft Windows. The security update addresses the vulnerability by correcting validation of shortcut icon references.

This security update addresses the vulnerability first described in Microsoft Security Advisory 2286198.


Jeffa