James O'Neill's blog

Windows Platform, Virtualization and PowerShell with a little Photography for good measure.

Deploying Vista SP1.

Deploying Vista SP1.

  • Comments 8
  • Likes

For the last year I have been saying that the mentality of waiting for a Service pack is a way of thinking which belongs to the 1990s (wait 6 months might make sense, but a service pack is not the milestone it was). Still, SP1 has released and whilst the majority of its changes were already pushed out though Windows update there are some additional bits in the SP1, so deploying it is, basically a Good Thing.

My laptop has been messed about with dreadfully over the last year and a bit. I blogged that sleep wasn't working properly, and the battery life was terrible. This turned out to be a faulty battery - I swapped it with one from an identical machine we have for roadshow demos and life went from less than an hour to somewhere between 3 and 4 hours. Fantastic. I also noticed that my BIOS was out of date, so I hatched a plan.

  • Use the demo laptop to build a complete image of everything I wanted
  • Image it (this image won't fit on one DVD) so
  • Split the image
  • Make ISO images for Installation Disks
  • Burn DVDs
  • Reformat my laptop, reinstall from the DVDs and restore my data from Vista's regular backup

I have a secondary hard disks which replaces the DVD in the laptop, and because Vista likes run backups as a scheduled task this is reasonably up to date, and I could do a clean installation. I made myself a Vista+SP1 install disk from the files on an internal server and got to work.

  1. Build Vista Ultimate 64 bit
  2. Plug in all my different USB devices, and configure drivers for them (that means my hand made storage driver for my old compact camera and downloading the driver for my TV stick from Hauppauge). Configure drivers needed for smartcard
  3. Configure Microsoft IT's VPN software
  4. Configure Media Centre TV settings.
  5. Add rights management Add in for Internet explorer
  6. Install Microsoft Office 2007 SP1 Enterprise + Visio + Communicator + Live Meeting
  7. Install my photography tools Digitial image suite + Groupshot + Paintshop Pro + Capture one + Advanced Batch Converter + Exifutils and some internal only ones.
  8. Install Powershell + PowerGadgets + Powershell extensions for one note
  9. Install PDF tools from Foxit Software, Flash , Quicktime and Silverlight and IE7 Pro.
  10. Install Virtual Earth and Google Earth (yes I have both ! Which is better depends on where you're looking)
  11. Install Suunto Dive manager
  12. Install Mind-Genius
  13. Install Windows Live writer 
  14. Apply everything offered by Windows Update
  15. Remove redundant fonts
  16. Re-arrange start menu

I didn't install any anti-virus software as that we get pushed down to me anyway, to keep the image size small I chose to leave MapPoint off and I forgot the driver for my Presenter Mouse . With the software more or less as I wanted it  next step was to run SYSPREP. I told it to generalize the machine as this should help the install process on different hardware. Then it was time to boot into Windows PE and image the machine. Out came my trusty bootable USB key from the prompt I had to run

imagex.exe /flags “Ultimate”  /capture c: C:\gold.wim "ULTIMATE Golden Image" /compress maximum /verify

I've explained this command line before. The crucial bit is without the /FLAGS switch you can't use the image on an install DVD. Since Gold.wim is way to big for a DVD the next step was to run

imagex /split C:\Gold.wim C:\install.swm 3000

This gives me Install.swm and install2.swm (an SWM - or split WIM file is just like a WIM. Experience tells me that setup will fail if the split files have WIM extensions).

Next step, make a folder named VistaDVD, in that make a folder named SOURCES and create a dummy INSTALL.WIM it. The XCOPY the vista install DVD into VISTA DVD. When it asks to overwrite INSTALL.WIM say no (that saves copying a huge file to delete it later) then remove the dummy install.wim and copy in INSTALL.SWM. Finally make a second folder named VISTA2 with a SOURCES folder and copy in INSTALL2.SWM

Now I can make two DVD ISO images.

oscdimg -n –m –lGoldDisc1 –h –b"D:\etfsboot.com" c:\VistaDVD c:\Vista1.iso   
oscdimg -n –m –lGoldDisc2 –h  c:\Vista2 c:\Vista2.iso

The extra bits in the first one make it bootable. Before burning the ISOs I copied then to my secondary disk, and booted up Hyper V. I created a new virtual machine and installed from the ISOs. Happy that worked I burnt the disks and reinstalled the demo machine using them. All seemed well.

I took one last backup of my laptop to the secondary disk and about 11:40 yesterday I booted from my new DVDs and set the installation in motion. It asks to swap to DVD2 during the copy phase and back to DVD1 at the end of it, and about 12:00 I went to lunch. I returned at 12:30 to find the machine had finished installing and was waiting for me to set up an initial user account. Setup has a few final tasks to do and then I was able to log in and join the domain, and log on with my usual account - creating an empty profile.

I took my machine to a 1:00 presentation and set the restore going - it failed because it needed to be able to check accounts against the domain. This was a bit unexpected as I'd done a partial restore on an unjoined machine without problems.  I plugged a network cable in and and 50GB or so restored at about 1GB per minute. I had to recreate my outlook offline store, set-up links with my phone and set a few other settings but start to finish the process was done inside 3 hours - and for most of that time I wasn't touching the machine.  One pleasant surprise was media center was ready to go when I plugged in my TV stick at home. The only unpleasant surprise was that MindGenius doesn't like being imaged when it has had a serial number entered: it wouldn't start. Since I still have the image I built on the demo machine I might go back and add the intellipoint drivers for the Mouse and remove and reinstall Mindgenius and make some new disks.  It only takes 7 steps (sysprep, imagex /capture imagex /split, 2 copies, 2 oscdimg, 2 burn operations)

My machine is definitely running better - how much that is SP1 and how much just cleaning it out I don't know. But the ease with which you can make build disks and give them to every laptop user in the company is just one more reason why I say Vista is superior to anything we've had before.

Comments
  • We started deploying Vista in August 2007 and finished by the end of October.  I don't regret deploying before SP1.  Pre-SP1 was ready for general use.  SP1 will only make Vista that much better.  The only plus I see to waiting for SP1 has nothing to do with the actual OS.  If you wait for SP1, there is a much larger body of documentation to draw from as opposed to when I started doing research in June 2007.

  • At least you can get SP1 James, the only way for us IT professionals to get it at present is via bit torrent :(

    Dave Clark, Newcastle University

  • Dave, that's one of the things about being inside Microsoft: I do get access to builds of Windows early.

    Those of us in the field are trying to reduce the delay before you can get it.

  • My colleague James O'Neill has a really simple step by step blog post on how to use the new deployment

  • How did you make the Vista + SP1 disc?  was the build already available or did you magically make it somehow?

  • Viral: internal share with the ISO on :-) Although you can patch the WIM for some updates this isn't possible for Service packs.

  • I'd rather download Vista with SP1 incorporated as per the ISO you found internally at Microsoft. I don't suppose you know when this will be availabe via MSDN would you?

  • Simon, understood.

    I've heard different dates from different sources. "The next few days" seems to be the general view. Sorry to be vague. As soon as I have something definite  I'll post it.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment