Sometime in the course of yesterday afternoon (UK time) Adobe changed something on their web site. When I connected to install reader the site couldn’t understand that Windows NT 6 in a browser string meant Windows Vista and it offered me Reader 7.0.7 for NT 4.0. Later on it recognised Windows Vista Beta, and offered me version 7.0.8. If anyone is expecting this minor increment to include an iFilter for Vista’s search, or support for the Reading Pane or [property] preview Pane then I’m afraid you’ll be disappointed, but hey, one step at a time.