Ciao a tutti, volevo evidenziare che importando il management pack di Exchange 2010
versione 14.02.0071.0 potremmo ritrovarci di fronte a questo alert Monitor,

[ The required SCOM hotfixes for Exchange MP are not installed ]

Trattasi
di un problema legato al fatto che all’interno del MP di Exchange 2010 viene
ricercata comunque la Cumulative Update 1 pur avendo nel nostro sistema già una
versione più recente.

Di seguito la parte di codice del monitor che punta a questo aggiornamento:

'SP1 version of SCOM starts with 6.0 and R2 starts with 6.1
If (Left(OpsMgrVersion,3) = "6.0") Then
        hotfixVersion = SP1FileVersion
kbLink = "http://go.microsoft.com/fwlink/?LinkID=167911"
ElseIf (Left(OpsMgrVersion,3) = "6.1") Then
        hotfixVersion = R2FileVersion
kbLink = "http://go.microsoft.com/fwlink/?LinkID=167912"
End If

'If versioncompare function returns 2, the hotfix version is higher than the installed version
If healthServiceVersion <> "-1" Then
    If 2 = VersionCompare(healthServiceVersion,hotfixVersion) Then
     ScomHotFixStatus = "BAD"
    End If
End If

In questo caso potremmo
disattivare l’alert con una override relativa alla classe Health Service dei nostri Exchange.

Nell'immagine sottostante potete vedere il monitor per il quale effettuare l'ovverride,

relativamente al gruppo "Microsoft Exchange Server 2010 All Server Computers"

 

Buon Lavoro,

Fabrizio