TMG Reports stop working after installing TMG 2010 SP1

TMG Reports stop working after installing TMG 2010 SP1

  • Comments 4
  • Likes

This post is about an issue that might occur after you install Forefront TMG 2010 SP1 and Reports start to show blank result. When this happens, the following Alert appears on TMG console:

The daily summaries could not be summarized into a monthly summary for "07/2010". This may cause the report for this period to be inaccurate. Verify that no prior reporting configuration alerts exist, and that the reporting services on the designated Forefront TMG report server are running and accessible from all the array members. Use the source location 1001.158.7.0.8108.200 to report the failure.

Summary definition extended error information:

Name: 'Initialization'.

Method: 'Open Connection'.

SQL error description: Login failed for user 'ISA_RS_USER'

The failure is due to error: 0x80040e4d

In this scenario access to the report links URLs: http://localhost:8008/ReportServer_ISARS or http://127.0.0.:8008/Reports_ISARS will also fail. This issue might happen in some scenarios where there is a ‘database logon failure as showed in the error description (error code 0x80040e4d means DB_SEC_E_AUTH_FAILED). To address this issue run the script fixsqlserverlogin_vbs mentioned in the article: http://technet.microsoft.com/en-us/library/ff717843.aspx.

Note: this resolution is specifically for this scenario, where this alert is logged. Do not run the script for in other scenarios with same symptom (reporting showing blank result) but without this alert.

When you run the script, you have to wait for each node to sync with EMS and then run it on second node in case of TMG 2010 Enterprise Edition and on single TMG 2010 server in case of standard server. This script allows admin to change the password so that connection to the database can be established using new password and reports can be fetched from that.

Authors
Suraj Sigh
Support Engineer
Microsoft CSS Forefront Security Edge Team

Yuri Diogenes
Sr Security Support Escalation Engineer
Microsoft CSS Forefront Security Edge Team

Technical Reviewer
Bala Natarajan
Sr Security Support Escalation Engineer
Microsoft CSS Forefront Security Edge Team

Comments
  • I'm sorry but that is not true. I ran the script and nothing happens. And yes, I got THE SAME ERROR.

    Cheers

    Vuk

  • Lots of issues out there with Reports - is there a BLOG entry somewhere that provides step by step instructions on how to get this going?  

  • I know its a very old post but i have gone through all the posts and blogs i could find but don' have a solution for my issue.

    After installing FTMG SP1 generating reports was not possible anymore. Initially the reports were blank for the Recurring report alone. The one time report would show all the info and graphs. Now when i try to generate a report i get the error 'The operation failed'.

    'The error occured on object 'reports' of class ;reports configuration' in the scope of array "XXXX"

    Any help would be most welcome. im really stuck and i need those reports ASAP. If i could get a solution to just get  the reports showing.

  • Check Firewall Logging Properties, Log storage format should be selected as SQL Server Express Database

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment