MS09-012 and ISA Server Standard Edition 14109 Failures

MS09-012 and ISA Server Standard Edition 14109 Failures

  • Comments 16
  • Likes

We've received several reports of ISA Server Standard Edition restart failures after installation of April's security updates.

<Update>
ISA Server 2006 update released
ISA Server 2004 update released
</Update>

The error message observed in this circumstance is: "Event ID 14109 (The ISA Server Standard Edition cannot run. Either the server is using more than 4 processors....)."

Notes:
1.
this specific problem only affects ISA Server Standard Edition and only when it's running on a computer that has a total of more than 4 CPU cores.
2. this issue does not affect Forefront TMG (MBE)

The problem occurs when you install the MS09-012 patch under very specific circumstances.  The Windows Sustained Engineering team is producing a detailed explanation of this behavior for the MS09-012 bulletin articles and will post that as soon as it's ready.

In the meantime, you can employ the following workaround to put your ISA Server back in service:

1. log on to the computer using a local administrator account
2. click the Start button, select Run
3. in the Run dialog, enter cmd and click OK
4. in the command window
    a. type attrib -a -s -r -h c:\boot.ini and hit Enter
    b. type notepad c:\boot.ini and hit Enter
5. at the end of the line under [operating systems], enter /numprocs=4
    Note: if you have multiple boot entries, you should add this entry to the end of the line that is used to boot the default OS instance where ISA Server runs
6. save the boot.ini file
7. in the command window, type attrib +a +s +r +h c:\boot.ini and hit Enter
8. reboot your computer

HTH,
Jim Harrison, Program Manager FF Edge CS

Comments
  • If you cannot start ISA on SBS after installing MS09-012 and receive &quot;Event ID 14109: (The ISA Server

  • Una actualización importante de MSFT afecta a ISA Server y provoca que esté no pueda arrancar. Ocurre

  • We experienced a different problem with this patch.

    After it was applied all PPTP VPN connection attempts failed with the following error reported in the log.

    118.93.241.222 ISAGATEWAY - TCP - - 20/04/2009 10:28:34 p.m. 64223 890 0 0 0x8007274d WSAECONNREFUSED 0x0 0x0 Firewall - 21/04/2009 10:28:34 a.m. 192.168.47.10 1723 PPTP Failed Connection Attempt [System] Allow VPN client traffic to ISA Server 118.93.241.222 External Local Host - -

    We removed the update and PPTP VPN connections worked again.

    Norman.

  • Norman, please contact CSS.

    If this update caused the VPN failure, it's something we need to understand right away.

    Jim Harrison,

    Program Manager, FF Edge CS

  • De afgelopen periode was nogal een periode van veranderingen. Zo was er de bijna overname van Sun door

  • News Security The Challenge of Information Security Management, Part 1 http://co1piltwb.partners.extranet.microsoft.com/mcoeredir/mcoeredirect.aspx?linkId=11740336&amp;s1=68628015-2ccc-cbc7-31b9-0e76c3415474

  • I just applied the last set of updates to my ISA 2006 server. Single CPU, hyperthreaded.

    After applying the updates I could not get my VPN clients to connect, same as previous entries.

    I then removed KB956572 and KB952004, rebooted and was then able to get my VPN clients to connect.

    Since applying these updates RAS does not start automatically any more, so I am assuming there are other problems with some of the updates that were applied.

  • Error message WSAECONNREFUSED when trying to PPTP to ISA Sever. Same solution as SNORBERG.

    After removing KB956572 and KB952004 RAS on ISA Server was listening again on port 1723.

  • Hi,

    We have had this same issue but for a different patch -from June 2013.

    This fix worked but we have an 8 core HP server now running with 4 processors.

  • Hi All

    Same issue as Rich above, but in July 2013 - Must be another update that caused it but not sure which. I had installed updates yesterday evening and after reboot no ISA. The mod above has got it back online but with only 4 cpu. would like to find a proper solution? Any ideas anyone?

    Cheers

  • I had the same problem with Latest updates. Did it happen to you on SBS 2003?

  • Got the same problem now with the latest patches. Not sure which of them.

    Please try to find the fault...... We're running our server on half impulse.....

  • Just had the same issue tonight after installing updates today.  Just reducing the cores, and rebooting

  • Update: Reducing the cores via the boot.ini file worked fine.

    I then installed the hotfix 932370 as detailed in KB970450 and KB970454, reverted the boot.ini back to as it was (all cores) and rebooted - ISA starts this time and all 8 cores back again.

    Still not sure which update actually did the deed, but at least it seems to resolve it for the time being.

    I can probably list the ones it did update here later on, so that others can see if they did the same.

  • I just updated our SBS 2003 with ISA2004 (SP3) and have same problem. I printed out the updates applied prior to the reboot:

    all KBs:

    2807986

    2772930

    2820917

    2804577

    2820197

    2833949

    2833940

    2832411

    2834886

    2803821

    2840629

    2845187

    2850851

    2849470

    2859537

    2862772

    2863058

    2844285

    2850869

    890830

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment