Hola

Nos gustaría recalcar que la versión de SQL Server 2012 en instalaciones WSS 3.0 o de MOSS 2007 está no soportada.

Normalmente la suportabilidad de productos es siempre el requerimiento mínimo + 2 versiones, salvo excepciones. Por lo cual, como SQL Server 2000 era el requerimiento mínimo las dos siguientes versiones son SQL Server 2005 y SQL Server 2008/R2.

Además, en SharePoint 2010 deberás estar al menos en SP1 para poder usarlo como podéis comprobar en el siguiente link:

http://support.microsoft.com/kb/2460045

Muchas Gracias.

Un saludo.

Héctor Calvarro Martín. SharePoint Dev/Core. Microsoft Support Escalation Engineer for EMEA