web metrics
Office 2007 SP2 and PDF version support - @Pot&Kettle - Gray Matter - Site Home - TechNet Blogs

Gray Matter

Gray Knowlton's blog on Microsoft Office

Office 2007 SP2 and PDF version support - @Pot&Kettle

Office 2007 SP2 and PDF version support - @Pot&Kettle

  • Comments 3
  • Likes

I wanted to discuss a specific coverage area for Office 2007 SP2.

I was recently directed toward the Acrobat Team blog, which is pointing out some of the differences between Adobe Acrobat 9 and Office 2007 SP2. As explained in the post, Adobe has worked hard to add value to the Office platform with the Acrobat product family. They are a valued Office partner and solution provider. And it sems that Adobe has invested heavily in Acrobat well beyond the creation of PDF documents… and for good reason. A search for Free PDF Creation on the web gives you 21,000,000 hits. While I am certain there are not 21 Million providers of no-cost PDF creation tools, a wide proliferation of PDF creation technology exists for no cost or a very low cost.

We added support for PDF because it is the most commonly exchanged document format on the web, and was the #2 requested feature of our customer base. In that sense, we are in good alignment with Adobe in this regard:

“For Reader, there will likely be more PDF files in the world for users to consume using the product. And for Acrobat, the more PDFs that are created the more users will be interested in doing additional things with those documents”

It’s seems that Adobe is trying to help folks understand why Acrobat provides value to the work environment, and I have no argument with that as a long-time Acrobat user who enjoys the product. The area I’m struggling with is the portion that draws a contrast to our PDF support vs. what you get with Acrobat 9.

A quote from the post:

“Regarding PDF in particular, Microsoft has mentioned SP2 will support the creation of PDF 1.5 files from some Office applications. The specification for PDF 1.5 was first published by Adobe in 2003 and was supported that same year in Acrobat 6. Acrobat 9, the current release of the product line, supports PDF 1.7 files, which was the version ratified as ISO 32000. Jim King has an informative blog that, in part, talks about the ISO standardization process of PDF.”

This is strange because I don’t see us as being dramatically different than Acrobat in this area. Let’s just state for the record what SP2 actually supports:

-          All of the PDF that we write is intended to be compliant with ISO 32000, even if marked with the 1.5 version header.

-          Optionally, users can create PDF documents that are also intended to be compliant with the ISO 19005 (PDF/A) subset of ISO 32000.

The reason I took the time to write this post is to point out an apparent contrast between what Adobe seems to be implying in the statement above vs. what is supported out of the box in their Acrobat products. A quick scan of the Acrobat 9 Distiller settings files (the primary vehicle for creating PDF documents with Acrobat) reveals something that doesn’t jive with the blog post. Acrobat 9 “Standard” Job Options (the default for creating PDF documents) default to the same version of PDF that our add-in does, PDF 1.5. The screen shot below makes that pretty clear. In essence, the same data point Adobe is raising at SP2 is equally valid for Acrobat 9. Very much a “Pot/Kettle” type situation (call PDF versioning a problem if you find it to be one.)

http://blogs.technet.com/photos/gray_knowlton/images/3235051/original.aspx 

I’m not sure why Adobe would call that out for us when the behavior is a perfect mirror to their product.

Our reasons for choosing the Adobe PDF 1.5 spec / Acrobat 6 as the default was to optimize for maximum compatibility with existing products on folks’ desktops. I’ll refrain from speculating about Adobe’s reasons for defaulting to PDF 1.5, but we should be clear that the default PDF version is the same between SP2 and Acrobat 9.

 

We could also conduct the discussion in a different way. Adobe has posted a document that is a copy of the IS32000 standard where the “technical content is identical including the section numbering and page numbering.” The Conformance Clause of that specification, section 2.6:

“6 Version Designations

For the convenience of the reader, the PDF versions in which various features were introduced are provided informatively within this document. The first version of PDF was designated PDF 1.0 and was specified by Adobe Systems Incorporated in the PDF Reference 1.0 document published by Adobe and Addison Wesley. Since then, PDF has gone through seven revisions designated as: PDF 1.1, PDF 1.2, PDF 1.3, PDF 1.4, PDF 1.5, PDF 1.6 and PDF 1.7. All non-deprecated features defined in a previous PDF version were also included in the subsequent PDF version. Since ISO 32000-1 is a PDF version matching PDF 1.7, it is also suitable for interpretation of files made to conform with any of the PDF specifications 1.0 through 1.7. Throughout this specification in order to indicate at which point in the sequence of versions a feature was introduced, a notation with a PDF version number in parenthesis (e.g., (PDF 1.3)) is used. Thus if a feature is labelled with (PDF 1.3)it means that PDF 1.0, PDF 1.1 and PDF 1.2 were not specified to support this feature whereas all versions of PDF 1.3 and greater were defined to support it.”

Read: PDF 1.5 files are inherently compliant with 1.7, and “since ISO32000-1 is a PDF version matching PDF 1.7”, one can conclude that PDF 1.5 documents are also IS32000 compliant. (I’m probably oversimplifying that, but this section of the text in the PDF 1.7 document on the Adobe site seems to be very clear on the point.)

I’m not claiming that SP2 supports any new PDF 1.6 of 1.7 functionality.  Per the definition outlined in the PDF 1.7 / copy of the ISO32000 spec, however, we’re aligned with Adobe on our ability to produce PDF 1.5 files by default, PDF/A compliant files as an option, and (at least in the simplest definition) conformant with the IS32000 and IS19005 specifications. As I can see there is little difference.

It is worth pointing out that we were relatively late to the game for business productivity suites supporting PDF export; PDF creation is supported everywhere from the Mac OS to OpenOffice. Since (per the quote above) the PDF specification has been published since version 1.0, and prior versions are inherently compliant to future versions, I’m not sure why the version distinction matters as much, or where we should be doing more with the format, or for that matter, how we are different from anyone else. I’m not sure what motivation Adobe has in implying that PDF producers must write the most recent PDF version header into the documents they create. The spec doesn't support that assertion.

I raise this not to pick on Adobe of course, I used to work on the team who publishes this blog, and I know the author of the post; I have a healthy respect for both. But I am hopeful that these issues are bringing the IS29500 discussion into the same light as we’re viewing some of the challenges emerging with the two other significant document format standards in play.

Comments
  • PingBack from http://www.netdeluxo.com/blog/blogs/gray-matter-office-2007-sp2-and-pdf-version-support-potkettle/

  • It's only 15:17 where I am in Pacific Daylight Time, so I can't figure out the time-stamp on this post.

    So, was this written before or after you "met the man?"  [;<).

    Thanks for this post.  I don't understand the reason to point to SP2 creating PDF 1.5 out-of-the-box either, since it simply provides assurance that most of the Acrobat (er, sorry, Adobe) Readers on people's computers can probably read it.  I am so PDF-unaware that I didn't even know there was a PDF/A option as well.  Good for you.

    I am sufficiently satisfied about that, as someone who would want to produce only highly-portable versions of PDF, that I am not even going to worry about whatever version OO.o produces and proposes to be able to read and edit, when equipped with the appropriate plug-in.

  • Hi Dennis,

    the timestamp on the post is (I think) GMT. I pretty much banged out that post (including the typos) after I met the man.  (http://tinyurl.com/d6fwhs -- in case you are not familiar with "The Man". http://www.twitter.com/gray_knowlton)

    I would suspect (altough I couldn't be sure) your PDF experience is likely common to others, for me the "can I open it" test is about as far as I get these days. Common sense seems to point the development team in the direction of supporting older versions to enable more desktops to read the files. I'm not sure what version OO.org uses, or the MacOS or any other products, but I'd hazard a guess that it's not PDF 1.7 yet.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment