Bonjour,

Je voulais vous avertir que nous avons détecté plusieurs anomalie lors de l’application du Cumulative Update d’aout pour Project 2010:

  1. Lenteur d’installation. il nous a fallu en général au moins 5 heures pour l’installer
  2. Le PSConfig génère une exception causée par l’erreur suivante:

    [OWSTIMER] [PublishedDatabaseSequence] [ERROR] Upgrade object too new (build version = 14.0.7010.1000, schema version = 14.2.151.0). Current server (build version = 14.0.7104.5000, schema version = 14.1.702.0)

  3. La Base Draft est corrompue car la plupart des Vues SQL ont été supprimées mais pas restaurées.
  4. La version de la Base Published n’est pas mise à jour et reste en version SP2
    

Le problème se produit lorsque la séquence d’installation est la suivante: SP1 –> SP2 –> August CU. Nos tests ont montré que si le CU de juin était installé avant le SP2, alors le problème ne se posait pas car la version de schéma avait déjà été mise à niveau.

Dans les autres cas, le SP2 met à jour le numéro de version de schéma de la base Published à 14.2.151.0.

image

A l’instar des autres schéma, celui de la base Published devrait être sous la forme 14.1.xxx.0 et non pas 14.2.xxx.0.

Au moment de la mise à jour des bases de données (étape 9 du PSConfig), une erreur apparait car la version du schéma du CU d’août est 14.1.xxx.0 et est donc inférieur à celui de la base Published. Le processus de mise à jour s’arrête et les bases Published, et Draft ne sont pas complètement à niveau.

Ce problème sera corrigé dans le CU d’octobre.

Pour résumer:

  • Si vous avez installé le [SP1 + tout autre CU], vous pouvez installer le CU d’août
  • Si vous avez besoin d'installer le [SP2], alors vous devez installer le CU de Juin au préalable. Ce CU met à jour les bases de données faisant en sorte que le SP2 n’a pas besoin de les modifier. La version de schéma des bases reste donc sous la forme 14.1.xxxx.0. Vous pouvez alors installé le SP2 sans problème.
  • Si vous voulez installer le [SP2 + CU d’août], alors vous devez installer le CU de juin au préalable ou attendre le CU d’octobre
  • Si vous avez déjà installé le [SP2 + CU d’août] et que votre environnement est endommagé, vous devez utiliser la solution suivante pour réparer :

 

  1. Changer manuellement la version du schéma de les bases Published des instances PWA existantes:       
      
    image
  2. Exécuter le PSConfig avec la ligne de commande:

    PSCONFIG -CMD UPGRADE –INPLACE B2B -WAIT -FORCE

    clip_image002

Au final, la version de la base Published doit être 14.1.702.0.

Bonne journée,

Marc Biarnès